By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,456 Members | 1,251 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,456 IT Pros & Developers. It's quick & easy.

Report Error

salimudheen
P: 14
In my system the access report is open perfectly. But another system is not working. It display the error message as following
The Report name “test” you entered is misspelled or refers to a report that isn’t open or doesn’t exist.

But my report name is correct .... and also exist.... why this error happened?
Oct 5 '07 #1
Share this Question
Share on Google+
3 Replies


nico5038
Expert 2.5K+
P: 3,072
Check the references on the "error machines".

Open some VBA code (e.g. by pressing [CTRL+G]) and select Tools/References.
Each libraryname starting with "MISSING" must be unchecked and (e.g. microsoft DAO version x.xx) replaced when necessary.

As access doesn't cleanup added libraries, often unnecessary refenreces are present.
Just delete as many as possible without getting an error executing "Debug/compile all modules"

Nic;o)
Oct 5 '07 #2

salimudheen
P: 14
Hi..
My client says they never missing any reference.... But they face the problem only to click the print button in the form...... Like "The open report action was cancelled", "The form u typed is misspelled or doesnt exist","U cant disable a control while it focus"..... like that.......
How to rectify this....
Oct 6 '07 #3

nico5038
Expert 2.5K+
P: 3,072
Let your client change the default printer or, when that doesn't work, let the printer driver be removed and reinstalled.

Another option would be to have the client open the report in designmode and to use File/Pagesettings to slightly ajust the settings. When saving the report the current default printer will be saved too.

Nic;o)
Oct 6 '07 #4

Post your reply

Sign in to post your reply or Sign up for a free account.