472,779 Members | 1,812 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,779 software developers and data experts.

Could not update; currently locked by another session on this machine

Could not update; currently locked by another session on this

I have the following objects:
Table1 - HO (which has about 51,000+ records)
Table2 - Contact (which has 68,000+ records)
Table3 - Notes (which has 69,000+ records)
They are linked in the relationships as a "1 to many" relationship
with cascading changes and deletes based on the company name in the
Table being the "1" and the company name in the Contact and Notes
tables being the many.
So I created a MAIN form based on the HO table and on that form I
2 x SUB forms that link as parent and child fields on the same
name field in the Contact and Notes tables. The sub forms have only
few fields from each record that show up and the)y are set up as
"Continuous Forms" in the "default view" property of the subform so
that multiple records will show up on the main form allowing our
people to see the essential information about each of the subcontacts
of the HO and the multiple notes (if the company indentified in the
table has many of them).
When you double click any of the fields in either of the sub forms,
runs a macro that open another form "BIG NOTES" (with a default view
property of "single form" which has all the remaining fields for that
record in the corresponding subform.
THE PROBLEM - (and this is Bizzarre and why I need help)
If I edit the memo field in the subform on the MAIN form, I have no
errors BUT
if I edit the memo field in the BIG NOTES form when I close it I get
the error message
"Could not update; currntly locked by another session on this
Note that this is NOT for all the records in the database, it is
happening only to a selct few of them.
Stranger yet,
I can edit other non-memo fields in this form and I DO NOT get any
error message.
Stranger yet,
If I add another record to the notes, I can edit the memo field in
the first record, buit if I then delete that second record, I get the
error message again in the first record
Stranger Yet,
If I close the MAIN form, I cen edit the memo field in the BIG
Any help would be greatly appreciated.

May 31 '07 #1
0 3134

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: akiddo | last post by:
Working in Access 2000: I have found several posts for this error message in various forums across the internet, but no answers. Can anyone explain why this happens? It only seems to occur...
by: Andrew Donnelly | last post by:
I am trying to update a memo field in a table from a form that I have created. The form is unbound, and once the user makes their changes, they have to click the continue button. Once the button...
by: David W. Fenton | last post by:
A very old app of mine that's been in production use, and largely unchanged since about 1998 has started recently throwing error 3188 (can't update, locked by another session on this machine) when...
by: Mark Reed | last post by:
Hi All, I'm having a problem with the following code. I've read quite a lot of old posts regarding the issue but none seem to affer a solution. The scenario is. I have a bound form which...
by: StephenWeiss | last post by:
Have a vb6 program that was connecting to an Access 97 database. We have converted the database to Access 2003 and changed the provider to use Jet 4.0 Now we are running into Could not update;...
by: CWogksch | last post by:
Hello, Everyone... My name is Chris Wogksch. I have a point of sale application developed in VB6 using MS Access 2003 as the database. I've been running versions of this app for over eight...
by: mike2020 | last post by:
I am using VB 6, ADO and Access in my Apps. I have one table which has a Memo field, and while saving recordset (rs.Update), at that point I am receiving the following error "Could not save;...
by: stuart | last post by:
I have 2 users who ran into a problem with a data entry program (written in Access 2003). One user was keying into one of the forms when she got the message "ACCESS Error Number: 3218 Could not...
by: fniles | last post by:
One of our application uses VB6 and Access97 database. Another application uses VB.NET 2005. This morning for about 15 seconds when the application tries to read either a query or a table from the...
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: linyimin | last post by:
Spring Startup Analyzer generates an interactive Spring application startup report that lets you understand what contributes to the application startup time and helps to optimize it. Support for...
by: Taofi | last post by:
I try to insert a new record but the error message says the number of query names and destination fields are not the same This are my field names ID, Budgeted, Actual, Status and Differences ...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: lllomh | last post by:
How does React native implement an English player?
by: Mushico | last post by:
How to calculate date of retirement from date of birth
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.