By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,679 Members | 2,069 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,679 IT Pros & Developers. It's quick & easy.

failure in saving new added field

P: n/a
-
I had added a new field to a form, and try insert the data to the new
created table field. But when i try to assign the a control source for that
form field, in the control source drop down list it doesn't show the new
field from that table.
Got any solution to solve this problem?
Dec 27 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
I had this same issue earlier tonight. The problem is that it seems access
takes a "snapshot" of your table when it opens. The only solution I found
was to exit access, and get right back in. At that point, my newly added
field(s) were there.
"-" <le******@yahoo.com.sg> wrote in message
news:43**********@news.tm.net.my...
I had added a new field to a form, and try insert the data to the new
created table field. But when i try to assign the a control source for that form field, in the control source drop down list it doesn't show the new
field from that table.
Got any solution to solve this problem?

Dec 27 '05 #2

P: n/a
Save any changes you have made to the form.
Close it.

After adding the new field to your table, saving the change, and closing the
table, open the form again in design view, and you should see the new field
appear in the field list now.

If it still does not appear, make sure the Name AutoCorrect boxes are
unchecked under:
Tools | Options | General
and then compact the database.

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"-" <le******@yahoo.com.sg> wrote in message
news:43**********@news.tm.net.my...
I had added a new field to a form, and try insert the data to the new
created table field. But when i try to assign the a control source for that
form field, in the control source drop down list it doesn't show the new
field from that table.
Got any solution to solve this problem?

Dec 27 '05 #3

P: n/a
What happens if you simply close the form and reopen it?

I usually just type in the control source for my fields if they don't
show up in the Field List or in the Control Source drop-down. You know
it exists, it's just not visible.

Dec 27 '05 #4

P: n/a
On Tue, 27 Dec 2005 15:59:48 +0800, "-" <le******@yahoo.com.sg> wrote:
I had added a new field to a form, and try insert the data to the new
created table field. But when i try to assign the a control source for that
form field, in the control source drop down list it doesn't show the new
field from that table.
Got any solution to solve this problem?


I have found that going to SQL view of the form's recordsource, highlighting all text (Ctrl A), cutting all text (Ctrl
X) and immediately pasting the text back (Ctrl V) will force the structure to be re-evaluated and the new fields will
show up.

Wayne Gillespie
Gosford NSW Australia
Dec 28 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.