By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,773 Members | 2,583 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,773 IT Pros & Developers. It's quick & easy.

Problem with rounding in MS-Access 2003

P: n/a
All my number data in Access 2003 automatically rounds to the nearest
interger, even when I request a 2 decimal place format. Is this a
known bug and is there a fix for it?
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Open the table in design view.
Select the problem field.
In the lower pane, change the Field Size propery from "Long Integer" to
"Double".

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Avery" <av***@TodaysConstruction.com> wrote in message
news:94**************************@posting.google.c om...
All my number data in Access 2003 automatically rounds to the nearest
interger, even when I request a 2 decimal place format. Is this a
known bug and is there a fix for it?

Nov 12 '05 #2

P: n/a
av***@TodaysConstruction.com (Avery) wrote in message news:<94**************************@posting.google. com>...
All my number data in Access 2003 automatically rounds to the nearest
interger, even when I request a 2 decimal place format. Is this a
known bug and is there a fix for it?


Umm... show us the code! What kind of field are you storing it in?
Is it a Single or a Double or Currency? Otherwise, it'll get
truncated.
Nov 12 '05 #3

P: n/a
Make sure you're using the right numeric type when adding a field into
a table - the default is long - which is an integer

av***@TodaysConstruction.com (Avery) wrote in message news:<94**************************@posting.google. com>...
All my number data in Access 2003 automatically rounds to the nearest
interger, even when I request a 2 decimal place format. Is this a
known bug and is there a fix for it?

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.