By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,257 Members | 1,294 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,257 IT Pros & Developers. It's quick & easy.

XP Printing to Custom Paper Size

P: 1
I have set up a custom paper size on a Windows XP SP2 machine. I have followed all of the directions that I can find. It does appear in the print server properties, but when I go to the advanced printing preferences, and click on the dropdown for the paper size, it does not appear.

I have tried virtually everything I can think of, and have already read. Please help!
Jul 31 '06 #1
Share this Question
Share on Google+
10 Replies


P: 12
I have set up a custom paper size on a Windows XP SP2 machine. I have followed all of the directions that I can find. It does appear in the print server properties, but when I go to the advanced printing preferences, and click on the dropdown for the paper size, it does not appear.

I have tried virtually everything I can think of, and have already read. Please help!
Re-install the printer. Make sure to remove it completely from the system. Does this happen with other printers on the same system? If not, then there is something wrong with the drivers install for that device. Also, try getting updated drivers from the MFR website. Give it a try and let me know, cheers!

Good advice here izzy

-Cyberdyne
Windows Forum Moderator
Sep 3 '06 #2

P: 25
You might want to install the updated printer driver on the server
Sep 20 '06 #3

Cyberdyne
Expert 100+
P: 627
Were you able to solve the problem>?

If not, give us the model number for the printer and we will provide you with the website for the drivers.

Good Luck.
Sep 26 '06 #4

P: 2
I have hit the same problem and have found that you can enter custom pages sizes through the printer server properties and they are registered but you cannot select them when printing. Two things are happening. Some printers like my 1220c appears to accept custom pages sizes only through it's own driver interface and not through the windows forms. The second is that custom page sizes set up using server properties may fall outside the acceptable bounds of the printer.

The first is a function of the printer driver and i have found no way around that at present using the vb6.0 printer object or in fact using the page selection through the API recommended by Microsoft. the second you check the minimum and maximum page sizes the printer will accept using device capabilities to make sure that the form you are entering falls within the accepted range of the printer. Most printers will then accept the form as setup. (Those that do not exhibit the behaviour in the first scenario).

I know this muddies the situation but i do hope it helps.
Oct 25 '06 #5

P: 2
crz
I have the same issue in certain circumstances as well, however I am able to create most custom form sizes (very small...1.5" x 1.0", for example) and then select them in Word. In order for the printing to work properly, however, the page size in Word must match the page size in your custom form. The custom for will appear in the paper size list in Word. Since my page sizes are dynamic, I wrote code to make the printer form changes on the fly (matching my Word doc size).

What I've just run into is a problem with custom form sizes of less than 1.00" for page height. No error message is displayed, but it won't print properly either. By "properly", I mean that if I print to a PDF print device, I should get a 1.5" x 1.0" (to use example above) PDF page, not 8.5" x 11", which is the result. It appears if the form selection fails for some reason, it defaults to that. My default page size is 14" x 22". When the "defaulting" occurs, my custom form will not appear in the list of paper sizes in Word. Haven't tried playing with the other end of the spectrum yet (14" x 22").

-Chris
Nov 30 '06 #6

P: 2
crz
I found that my problem printing to page sizes smaller than 1 inch turned out to be the parameters of the printer driver. Many printer drivers only allow page sizes down to 1.0 inches.

If the page size you specified is outside of the parameters supported by the printer, then the print form will not appear in your list. Windows filters it out. This will vary by printer driver, but you can check the maximum page size range (for postscript printers) by selecting 'Printing Preferences', going into the 'Advanced' dialog, and looking in the list of paper sizes. If custom sizes aren't allowed, you have to choose one of the page sizes given. If a custom postscript page size is allowed, select that and it will give you the minimum and maximum values allowed for page height and width.

-Chris
Dec 1 '06 #7

P: 1
I've dot matrix paper size 5.24" x 2.48 ",where/how to check setup paper size in Epson LQ 2180 dot matrix printer whether the size comply or not since the form paper size in server properties doesn't appear in page setup printing properties. thanks in advanced.
Dec 4 '06 #8

P: 1
I've been working on this all day on an Epson. Have found that if you Add a new LOCAL printer, Created on 'Create A New Port', specified as \\MyPC\MyPrinterThatYouWantToGetWorking
then all the forms that you create in Printer, File, ServerProperties. become visible.
Hope this helps.
Feb 4 '07 #9

P: 1
I think this may solve your issue - ask copied from the Microsoft support forum:

http://office.microsoft.com/en-us/publisher/HA011295761033.aspx

- Click Start, and then click Printers and Faxes.
- Select the icon that represents the printer that you want to use.
- On the File menu, click Server Properties.
- Click to select the Create a New Form check box.
I - n the Form Name text box, type the name that you want to use.

For example, if you have to have a Letter Extra paper size, type Letter_Extra. This name must not match a name that is already on the list of paper sizes.
Under Paper Size, type the height and width in the Height and Width text boxes.
- Click Save Form, and then click Close.

Good luck!
Jul 10 '08 #10

P: n/a
richmb thanks for this old post, it really helps a lot...
;-)
Oct 26 '10 #11

Post your reply

Sign in to post your reply or Sign up for a free account.