467,867 Members | 1,566 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,867 developers. It's quick & easy.

Compiler Error: Can't find library

100+
Hello Experts
I got a problem that I can't solve onmy own. I hope to get a solution from you guys.I was working on project on my PC and some times I use to work on my laptop(when I was away from my PC). I t work good at both spots. For some days when I execute my project I get this error:

Compile error: Can't find project library
if I say ok, it takes me to available reference window. IT points to Missing Jet and Replication object 2.6 Library

It seems version problem but I can't fix it. Pease help me get rid of this problem.

thanks in advance
Farhana
Oct 17 '07 #1
  • viewed: 1783
Share:
8 Replies
debasisdas
Expert 4TB
The problem might be because of missing / corrupted .DLL files in the system.
Oct 17 '07 #2
100+
Whayt I should do now? reinstall VB or copy .DLL file(I am not sure if I can do that)
Farhana
Oct 17 '07 #3
100+
Hi everyone
Please help me what I should do to this problem, I have tried reinstalling VB6 but problem still exist.
any suggestions? should I think I won't be able to run my project on my laptop?

thanks in advance
Oct 25 '07 #4
debasisdas
Expert 4TB
You need to copy the missing files from some other system and paste in system32 directory. next you need to register the files using REGSVR32 key.
Oct 25 '07 #5
9815402440
100+
hi

reinstall microsoft access in your system. if it is alreay installed then compare its version in both systems.

this will solve your problam

regards
manpreet singh dhillon hoshiarpur
Oct 25 '07 #6
100+
Well I been using my project on my laptop and it worked fine and I got no such errors.When i tried it after few weeks, I got these errors.
I tried this after reinstallin VB , but problem still persists.
thanks
Oct 26 '07 #7
100+
Hi everyone
the error is fixed finally. I thought It good idea to post my steps to fix the error, it might help someone else too. First of all, I tracked the errors and relating Missing references and identified reference name. Then I researched for corresponding .dll files and copied the files with other .dll files.

Removed the existing Missing references from the projects/reference and then referenced them to the newly installed files. It fixed all bugs and compiler errors. I saved and reopened
the project and it worked fine.

Reason: Why we got these errors?
The required .dll files are missing or they are corrupt(not in my case)
Some time this error occurs when a project (created in a computer that has newer version of MDAC) is operated on a machine that has old version.

regards
Farhana
Oct 26 '07 #8
debasisdas
Expert 4TB
Thanx for posting this . It will really help others in finding the solution in days to come.

You never forget anything that you learn by intrest.
Oct 26 '07 #9

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

3 posts views Thread by dbrown2 | last post: by
2 posts views Thread by Mike Fisher | last post: by
2 posts views Thread by Mary | last post: by
4 posts views Thread by Frank Rizzo | last post: by
3 posts views Thread by Hamilton | last post: by
55 posts views Thread by Steve | last post: by
reply views Thread by Henrik Stidsen | last post: by
13 posts views Thread by Albert | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.