By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,857 Members | 1,768 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,857 IT Pros & Developers. It's quick & easy.

Web Service and Listbox data source

P: 10
Hi,
I hav a web service which pull records from a database and I am hosting these services in IIS which works fine but I am trying to retrieve the record and display the record in a listbox displaying the time field as the text for that record.
I have created the following function

public sub get_data()
dim dt as new data.dataTable
dim service as ws webservice.webservice
service = new wswebservice.webservice
dt = service. getdata(lstboxrecod.text)
emptylistbox.datasource = dt
emptylistbox.displaymember = "time"
emptylistrbox.valuemember= "record_ID"

i can't see why this is failing whenever i execute on mymobile device the valuemember line has errors I checked the service its all spelt correctly

in the listbox i get system.data.datarowview it doesn't show the time in the listbox I have this working on another simillar page fine but here it falls over i cant understand why...


any help please would be gretly appreciated

Thanks

Kunal
Apr 18 '09 #1
Share this Question
Share on Google+
1 Reply


P: 10
I noticedthat on the load method it works fine but if I add an index changed method to change the text in various labels I get a System.Data.DataRowView which doesn't make sense why..
as it works fine in other parts of the app

Please can someone help

Kunal
Apr 19 '09 #2

Post your reply

Sign in to post your reply or Sign up for a free account.