469,333 Members | 4,378 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,333 developers. It's quick & easy.

VB.NET application printing to Epson serial printer

I am not sure if I am in the right group.

My problem is this:

My VB.NET application prints to the Epson printer using Epson OPOS
drivers. I have downloaded the Epson ADK for .NET from the EpsonExpert
site (www.epsonexpert.com) I have also downloaded the Epson Advanced
Printer Driver from the Epson site.
I have installed Microsot POS for .NET on a windows 2000 machine. The
installation completes but it throws an error "Error 5008. Registration
of WMI Provider failed. Return code 3". So I went in and manually
registered the msposwmi.dll.
Then I installed Epson ADK for .NET and set up my Epson TM-T88III
Receipt printer using the SetupPOS utility. When I try checking the
health of the printer using the CheckHealth utility, it gives me this
error:
************************************************** ************************************************** *******
================== Exception =====================
Microsoft.PointOfService.PosControlException
ErrorCode : Illegal (106)
ErrorCodeExtended : 0
Message : Failed the native method processing.
Target : Void Claim(Int32)
## StackTrace ##
at jp.co.epson.upos.pntr.CommonPrinterService.Claim(I nt32 iTimeout)
at CheckHealthTest.MainForm.ExecuteCheckHealth(Device Info objInfo)
at CheckHealthTest.MainForm.btnCheckHealth_Click(Obje ct sender,
EventArgs e)
---------InnerException-----------
jp.co.epson.pos.comm.CommControlException
Message : Failed : Win32API.SetCommState
Target : Void PortOpen()
## StackTrace ##
at jp.co.epson.pos.comm.SerialIO.PortOpen()
at jp.co.epson.pos.comm.PortControl.OpenPort()
at jp.co.epson.upos.pntr.CommonPrinterService.OpenPor t()
************************************************** ************************************************** ******
The Epson printer is a serial printer connected to COM1.

The VB.NET application prints to the USB and Ethernet printers of Epson
successfully using the OPOS drivers when set up in the same way as
mentioned above. This problem is coming only when I try printing to the
serial printer and setup the serial Epson printer.
As per the Epson site, the error code 106 is thrown when there is a
conflict in ports. But no other device is using COM1. However, I have
another doubt here-When I setup the printer using the Advanced Printer
Driver, it creates a new port ESDPRT01 which is assigned as a COM1 port
and is used by Epson to print.
Any ideas or maybe tell me which group should this be posted to?

Jan 10 '06 #1
0 7426

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

32 posts views Thread by Hank | last post: by
2 posts views Thread by Blue Bell Trading - Customer Services | last post: by
2 posts views Thread by The Bear | last post: by
2 posts views Thread by F. Potier | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by haryvincent176 | last post: by
reply views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.