By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,750 Members | 1,471 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,750 IT Pros & Developers. It's quick & easy.

Sql Server Timeout Problem

P: n/a
I have an application connected to an overseas sql-server using port 1433.
But recently it always timeout the connection. Any solution to avoid
this??? I am using the VB.net Windowed Form with .net 2002, SQL-Sever 2000
Enterprise
Thanks!
Nov 21 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
with you connection object you can set the timeout higher.
you could also make sure you can hit port 1433 before you try to create the
connection.

or where you declare your connection you can put it in a try catch statement
and loop until you have a connection.

"BBC1009" <be******@yahoo.com.hk> wrote in message
news:O4****************@TK2MSFTNGP09.phx.gbl...
I have an application connected to an overseas sql-server using port 1433.
But recently it always timeout the connection. Any solution to avoid
this??? I am using the VB.net Windowed Form with .net 2002, SQL-Sever 2000
Enterprise
Thanks!

Nov 21 '05 #2

P: n/a
Do you meant that set the "connection timeout" to higher? I already set it
to 600 but still time-out.

I delcare the connection on the first login form and keep open thru the
program. Is it a problem?
"Chris Calzaretta" <cc*********@hotmail.com> 级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl...
with you connection object you can set the timeout higher.
you could also make sure you can hit port 1433 before you try to create
the connection.

or where you declare your connection you can put it in a try catch
statement and loop until you have a connection.

"BBC1009" <be******@yahoo.com.hk> wrote in message
news:O4****************@TK2MSFTNGP09.phx.gbl...
I have an application connected to an overseas sql-server using port 1433.
But recently it always timeout the connection. Any solution to avoid
this??? I am using the VB.net Windowed Form with .net 2002, SQL-Sever
2000 Enterprise
Thanks!


Nov 21 '05 #3

P: n/a
My connection string is :

Data Source=xxxx.vicp.net;user Id=sa;password=abc;Initial
Catalog=ffs;Connect Timeout=600


"BBC1009" <be******@yahoo.com.hk> 级糶秎ン穝籇:%2******************@TK2MSFTNGP12.p hx.gbl...
Do you meant that set the "connection timeout" to higher? I already set
it to 600 but still time-out.

I delcare the connection on the first login form and keep open thru the
program. Is it a problem?
"Chris Calzaretta" <cc*********@hotmail.com> 级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl...
with you connection object you can set the timeout higher.
you could also make sure you can hit port 1433 before you try to create
the connection.

or where you declare your connection you can put it in a try catch
statement and loop until you have a connection.

"BBC1009" <be******@yahoo.com.hk> wrote in message
news:O4****************@TK2MSFTNGP09.phx.gbl...
I have an application connected to an overseas sql-server using port
1433. But recently it always timeout the connection. Any solution to
avoid this??? I am using the VB.net Windowed Form with .net 2002,
SQL-Sever 2000 Enterprise
Thanks!



Nov 21 '05 #4

P: n/a
Hi

I would only open the connection if you need it, because in .net the
connections get pooled, so I'd advise not to keep the connection open all
the time, I think this could cause a timeout, does the timeout occure when
you first want to connect or after a couple of minutes if the program is
already open?

Greetz Peter
"BBC1009" <be******@yahoo.com.hk> schreef in bericht
news:uL**************@TK2MSFTNGP12.phx.gbl...
My connection string is :

Data Source=xxxx.vicp.net;user Id=sa;password=abc;Initial
Catalog=ffs;Connect Timeout=600


"BBC1009" <be******@yahoo.com.hk>

级糶秎ン穝籇:%2******************@TK2MSFTNGP12.p hx.gbl...
Do you meant that set the "connection timeout" to higher? I already set
it to 600 but still time-out.

I delcare the connection on the first login form and keep open thru the
program. Is it a problem?
"Chris Calzaretta" <cc*********@hotmail.com> 级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl...
with you connection object you can set the timeout higher.
you could also make sure you can hit port 1433 before you try to create
the connection.

or where you declare your connection you can put it in a try catch
statement and loop until you have a connection.

"BBC1009" <be******@yahoo.com.hk> wrote in message
news:O4****************@TK2MSFTNGP09.phx.gbl...
I have an application connected to an overseas sql-server using port
1433. But recently it always timeout the connection. Any solution to
avoid this??? I am using the VB.net Windowed Form with .net 2002,
SQL-Sever 2000 Enterprise
Thanks!



Nov 21 '05 #5

P: n/a
When it connects to the local database, it should be no problem. The
problem only occur when connecting to the overseas server ie
Hongkong-->China.
We tried open the connection each time before but the performance is far
away from keep it open.
The first connect has no problem (login process) but it timeout when perform
a query or execute a sql.

Thanks
"Peter Proost" <pp*****@nospam.hotmail.com> 级糶秎ン穝籇:uv**************@TK2MSFTNGP14.phx.g bl...
Hi

I would only open the connection if you need it, because in .net the
connections get pooled, so I'd advise not to keep the connection open all
the time, I think this could cause a timeout, does the timeout occure when
you first want to connect or after a couple of minutes if the program is
already open?

Greetz Peter
"BBC1009" <be******@yahoo.com.hk> schreef in bericht
news:uL**************@TK2MSFTNGP12.phx.gbl...
My connection string is :

Data Source=xxxx.vicp.net;user Id=sa;password=abc;Initial
Catalog=ffs;Connect Timeout=600


"BBC1009" <be******@yahoo.com.hk>

级糶秎ン穝籇:%2******************@TK2MSFTNGP12.p hx.gbl...
> Do you meant that set the "connection timeout" to higher? I already
> set
> it to 600 but still time-out.
>
> I delcare the connection on the first login form and keep open thru the
> program. Is it a problem?
>
>
> "Chris Calzaretta" <cc*********@hotmail.com> 级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl... >> with you connection object you can set the timeout higher.
>> you could also make sure you can hit port 1433 before you try to
>> create
>> the connection.
>>
>> or where you declare your connection you can put it in a try catch
>> statement and loop until you have a connection.
>>
>>
>>
>> "BBC1009" <be******@yahoo.com.hk> wrote in message
>> news:O4****************@TK2MSFTNGP09.phx.gbl...
>>>I have an application connected to an overseas sql-server using port
>>>1433. But recently it always timeout the connection. Any solution to
>>>avoid this??? I am using the VB.net Windowed Form with .net 2002,
>>>SQL-Sever 2000 Enterprise
>>>
>>>
>>> Thanks!
>>>
>>>
>>
>>
>
>



Nov 21 '05 #6

P: n/a
How fast is the line to china? Maybe it isn't fast enough for a big query,
but it's fast enough for small selects
just my toughts...

Greetz
"BB2046" <ob*****@yahoo.com> schreef in bericht
news:#j*************@TK2MSFTNGP15.phx.gbl...
When it connects to the local database, it should be no problem. The
problem only occur when connecting to the overseas server ie
Hongkong-->China.
We tried open the connection each time before but the performance is far
away from keep it open.
The first connect has no problem (login process) but it timeout when perform a query or execute a sql.

Thanks
"Peter Proost" <pp*****@nospam.hotmail.com>

级糶秎ン穝籇:uv**************@TK2MSFTNGP14.phx.g bl...
Hi

I would only open the connection if you need it, because in .net the
connections get pooled, so I'd advise not to keep the connection open all the time, I think this could cause a timeout, does the timeout occure when you first want to connect or after a couple of minutes if the program is
already open?

Greetz Peter
"BBC1009" <be******@yahoo.com.hk> schreef in bericht
news:uL**************@TK2MSFTNGP12.phx.gbl...
My connection string is :

Data Source=xxxx.vicp.net;user Id=sa;password=abc;Initial
Catalog=ffs;Connect Timeout=600


"BBC1009" <be******@yahoo.com.hk>

级糶秎ン穝籇:%2******************@TK2MSFTNGP12.p hx.gbl...
> Do you meant that set the "connection timeout" to higher? I already
> set
> it to 600 but still time-out.
>
> I delcare the connection on the first login form and keep open thru the > program. Is it a problem?
>
>
> "Chris Calzaretta" <cc*********@hotmail.com>

级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl...
>> with you connection object you can set the timeout higher.
>> you could also make sure you can hit port 1433 before you try to
>> create
>> the connection.
>>
>> or where you declare your connection you can put it in a try catch
>> statement and loop until you have a connection.
>>
>>
>>
>> "BBC1009" <be******@yahoo.com.hk> wrote in message
>> news:O4****************@TK2MSFTNGP09.phx.gbl...
>>>I have an application connected to an overseas sql-server using port
>>>1433. But recently it always timeout the connection. Any solution to >>>avoid this??? I am using the VB.net Windowed Form with .net 2002,
>>>SQL-Sever 2000 Enterprise
>>>
>>>
>>> Thanks!
>>>
>>>
>>
>>
>
>



Nov 21 '05 #7

P: n/a
You can also specify the sqlcommand timeout,
SqlCommand.CommandTimeout

greetz Peter
"Peter Proost" <pp*****@nospam.hotmail.com> schreef in bericht
news:ea**************@TK2MSFTNGP14.phx.gbl...
How fast is the line to china? Maybe it isn't fast enough for a big query,
but it's fast enough for small selects
just my toughts...

Greetz
"BB2046" <ob*****@yahoo.com> schreef in bericht
news:#j*************@TK2MSFTNGP15.phx.gbl...
When it connects to the local database, it should be no problem. The
problem only occur when connecting to the overseas server ie
Hongkong-->China.
We tried open the connection each time before but the performance is far
away from keep it open.
The first connect has no problem (login process) but it timeout when

perform
a query or execute a sql.

Thanks
"Peter Proost" <pp*****@nospam.hotmail.com>

级糶秎ン穝籇:uv**************@TK2MSFTNGP14.phx.g bl...
Hi

I would only open the connection if you need it, because in .net the
connections get pooled, so I'd advise not to keep the connection open all the time, I think this could cause a timeout, does the timeout occure when you first want to connect or after a couple of minutes if the program is already open?

Greetz Peter
"BBC1009" <be******@yahoo.com.hk> schreef in bericht
news:uL**************@TK2MSFTNGP12.phx.gbl...
> My connection string is :
>
> Data Source=xxxx.vicp.net;user Id=sa;password=abc;Initial
> Catalog=ffs;Connect Timeout=600
>
>
>
>
> "BBC1009" <be******@yahoo.com.hk>
级糶秎ン穝籇:%2******************@TK2MSFTNGP12.p hx.gbl...
> > Do you meant that set the "connection timeout" to higher? I already> > set
> > it to 600 but still time-out.
> >
> > I delcare the connection on the first login form and keep open thru the> > program. Is it a problem?
> >
> >
> > "Chris Calzaretta" <cc*********@hotmail.com>
级糶秎ン穝籇:OS**************@TK2MSFTNGP14.phx.g bl...
> >> with you connection object you can set the timeout higher.
> >> you could also make sure you can hit port 1433 before you try to
> >> create
> >> the connection.
> >>
> >> or where you declare your connection you can put it in a try catch
> >> statement and loop until you have a connection.
> >>
> >>
> >>
> >> "BBC1009" <be******@yahoo.com.hk> wrote in message
> >> news:O4****************@TK2MSFTNGP09.phx.gbl...
> >>>I have an application connected to an overseas sql-server using port> >>>1433. But recently it always timeout the connection. Any solution to> >>>avoid this??? I am using the VB.net Windowed Form with .net 2002,
> >>>SQL-Sever 2000 Enterprise
> >>>
> >>>
> >>> Thanks!
> >>>
> >>>
> >>
> >>
> >
> >
>
>



Nov 21 '05 #8

P: n/a
BBC1009 wrote:
I have an application connected to an overseas sql-server using port 1433.
But recently it always timeout the connection. Any solution to avoid
this??? I am using the VB.net Windowed Form with .net 2002, SQL-Sever 2000
Enterprise
Thanks!

Have you considered Queued Components? If your app doesn't want to wait
for the overseas connection, a local queue may add the fault tolerance
you need.
Nov 21 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.