By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,806 Members | 1,837 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,806 IT Pros & Developers. It's quick & easy.

Connection Failed

P: n/a
I have added a domain global group to the local administrators group on server running sql 2000 with sp3a. The os on the server is w2k with sp4. The builtin\administrators group has sa rights. Yet members of the domain global group, after they logon to the server through a remote desktop session cannot open sql enterprise manager & connect to the local sql server (default instance). They get a message "Cannot open user default database. Login failed.." The users of the domain global group can connect to 2 other instances of of sql on the same server. The default instance is 8.00.818. The other 2 instances are 8.00.760. Thanks in advance for any advice.

*****************************************
* This message was posted via http://www.sqlmonster.com
*
* Report spam or abuse by clicking the following URL:
* http://www.sqlmonster.com/Uwe/Abuse....b2402cee65437e
*****************************************
Jul 20 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Mike Pavel via SQLMonster.com (fo***@SQLMonster.com) writes:
I have added a domain global group to the local administrators group on
server running sql 2000 with sp3a. The os on the server is w2k with sp4.
The builtin\administrators group has sa rights. Yet members of the
domain global group, after they logon to the server through a remote
desktop session cannot open sql enterprise manager & connect to the
local sql server (default instance). They get a message "Cannot open
user default database. Login failed.." The users of the domain global
group can connect to 2 other instances of of sql on the same server. The
default instance is 8.00.818. The other 2 instances are 8.00.760. Thanks
in advance for any advice.

Each login on an SQL Server has a default database. Now, if for some
reason they cannot access that database, login fails. This can be
because they don't have permission to the database or that database is
offline of non-existing.

You can use the stored procedure sp_defaultdb to change the default db
for a user. Please see Books Online for syntax.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 20 '05 #2

P: n/a
The domain global group is part of the nt local admins group on the server running sql which makes it part of the built\administrators group in sql which has dbo access to all the databases on the sql server. The default database does exist. Thanks for reponding to my question. Any more thoughts?

*****************************************
* A copy of the whole thread can be found at:
* http://www.sqlmonster.com/Uwe/Forum....ql-server/5079
*
* Report spam or abuse by clicking the following URL:
* http://www.sqlmonster.com/Uwe/Abuse....fff59ba325a2b2
*****************************************
Jul 20 '05 #3

P: n/a
Mike Pavel via SQLMonster.com (fo***@SQLMonster.com) writes:
The domain global group is part of the nt local admins group on the
server running sql which makes it part of the built\administrators group
in sql which has dbo access to all the databases on the sql server. The
default database does exist. Thanks for reponding to my question. Any
more thoughts?


Well, the error message you get, usually means that the default database
is not accessible. This can be because of several reasons:

o The database does not exist.
o The user does not have permission to the database.
o The database is offline or in single-user mode.

Can they log in through Query Analyzer or OSQL? In such case, change the
registration properties in Enterprise Manager.
--
Erland Sommarskog, SQL Server MVP, es****@sommarskog.se

Books Online for SQL Server SP3 at
http://www.microsoft.com/sql/techinf...2000/books.asp
Jul 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.