472,119 Members | 1,701 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,119 software developers and data experts.

rdiff-backup compilation error

We are trying to install rdiff-backup onto IBM AIX 5.3 system. But have got stuck up at some level. It would be a great help if you could atleast give us a hint as to what is going wrong where.


These are the steps we tried out on the system,

We have downloaded/untarred/compiled/installed the packages as shown below,

root@XXX.com:/home/tv/rdiff>ls -lrt
total 5408
-rw-r----- 1 root system 563200 Nov 26 14:23 rdiff-backup-1.0.5.tar
-rw-r----- 1 root system 2191360 Nov 26 14:28 librsync-0.9.7.tar
drwxrwxr-x 4 500 302 4096 Nov 26 14:35 rdiff-backup-1.0.5
drwxrwxrwx 8 500 500 8192 Nov 26 22:04 librsync-0.9.7

The librsync went well. But while compilation of rdiff-backup we are facing the below errors,

root@XXX.com:/home/tv/rdiff/rdiff-backup-1.0.5>python setup.py build
running build
running build_py
running build_ext
building 'rdiff_backup.C' extension
cc_r -DNDEBUG -O -qmaxmem=-1 -qcpluscmt -DAIX_GENUINE_CPLUSCPLUS -D_LARGE_FILES -I/opt/freeware/include/python2.3 -c cmodule.c -o build/temp.aix-5.3-2.3/cmodule.o
unable to execute cc_r: No such file or directory
error: command 'cc_r' failed with exit status 1

We also tried installing the same using ,

python setup.py --librsync-dir=/usr/local build .But same error.


Is there anything we are missing it out? Or is it something else. We are kindaa stuck up at this stage , any help would be really beneficial for us.
Request you once again to guide us. If any queries please go ahead.


Thanks in advance.

Regards,
Sachin
Nov 27 '07 #1
0 964

Post your reply

Sign in to post your reply or Sign up for a free account.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.