By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,836 Members | 2,023 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,836 IT Pros & Developers. It's quick & easy.

Boost Python tutorial needs MSVC?

P: n/a
Hi,

Has anyone here built Boost.Python modules under MinGW? I'm trying to
build the Boost.Python tutorial under MinGW and getting an error that
says it depends on MSVC, which puzzles me because Boost built using
g++. Here's some of my output:

Student@YGGDRASIL /c/Boost/libs/python/example/tutorial
$ bjam -sTOOLS=mingw -d+2
....found 1508 targets...
....updating 32 targets...
vc-C++
bin\boost\libs\python\build\boost_python.dll\vc-7_1\debug\threading-multi\numeric.obj
'"C:\Program Files\Microsoft Visual Studio .NET
2003\VC7\bin\VCVARS32.BAT"' is not recognized as an internal or
external command,
operable program or batch file.

CALL "C:\Program Files\Microsoft Visual Studio .NET
2003\VC7\bin\VCVARS32.BAT" >nul
"C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\bin\cl"
/Zm800 -nologo /EHsc -c -DBOOST_PYTHON_DYNAMIC_LIB
-DBOOST_PYTHON_SOURCE /Z7 /Od /Ob0 /EHsc /GR /MDd /Op /wd4675
/Zc:forScope /Zc:wchar_t -I"bin\boost\libs\python\build" -I"c:\Boost"
-I"c:\Python24\include"
-Fo"bin\boost\libs\python\build\boost_python.dll\ vc-7_1\debug\threading-multi\numeric.obj"
-Tp"c:\Boost\libs\python\build\../src/numeric.cpp"

[etc.]

1. I'm using the standard Python.org windows Python interpreter for
Python 2.4.3 (Enthought edition), and mingw g++ 3.4.5.
2. PYTHON_ROOT and PYTHON_VERSION have been set to /c/Python24 and 2.4
respectively.
3. I'm running the unmodified Jamfile/Jamrules straight from the Boost
subdirectory, and as you can see I'm using the sTOOLS=gcc option.
4. So why is it looking for Visual Studio and how do I stop it?

Any ideas much appreciated.

-Max Wilson

Dec 20 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Cancel that--I found the answer.
http://groups.google.com/group/boost...60f2038d6e6cca

Short answer: bjam.exe should not be in /bin or /usr/bin because MinGW
treats programs in there differently. In my case I simply copied
bjam.exe to my working directory, for now.

-Max Wilson

Dec 20 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.