By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,281 Members | 2,201 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,281 IT Pros & Developers. It's quick & easy.

Problem build python bindings to lasso with swig on mac os x

P: n/a
Hi!

This involves quite a lot of different system, so I'm not really sure
who which would be the right list to query.

So, I'm trying a couple, this list being one of them.

I'm trying to build the lasso (http://lasso.entrouvert.org/)
libraries and what I really want to get at is the Python bindings.
Those binding are done with the help of swig and it fails with the
following output:

gcc -o .libs/_lasso.so -bundle .libs/_lasso_la-lasso_wrap.o -L/sw/
lib -L/Users
/rolandhedberg/src/libxml2-2.6.22 -L/usr/local/lib -L/lib ../
lasso/.libs/liblasso
..dylib /usr/lib/libiconv.dylib /usr/lib/libpthread.dylib /usr/lib/
libz.dylib /usr
/lib/libm.dylib /usr/lib/libssl.dylib /usr/lib/libcrypto.dylib /usr/
local/lib/lib
dl.dylib /usr/lib/libresolv.dylib /usr/local/lib/
libgobject-2.0.dylib /usr/lib/li
bc.dylib /usr/local/lib/libglib-2.0.dylib /usr/local/lib/
libintl.dylib /usr/local
/lib/libxmlsec1-openssl.dylib /usr/local/lib/libxmlsec1.dylib -ldl /
usr/local/lib
/libxslt.dylib /usr/local/lib/libxml2.dylib -lpthread -lz /sw/lib/
libiconv.dylib
-lm -lssl -lcrypto /usr/local/lib/libsasl2.dylib -Wl,-F. -Wl,-F.
/usr/bin/ld: Undefined symbols:
_PyArg_ParseTuple
_PyCObject_AsVoidPtr
_PyCObject_FromVoidPtrAndDesc
_PyCObject_GetDesc
_PyCObject_Type
_PyDict_SetItemString
_PyErr_NewException
_PyErr_Occurred
_PyErr_SetObject
_PyErr_SetString
_PyExc_IOError
_PyExc_IndexError
_PyExc_MemoryError
_PyExc_NameError
_PyExc_OverflowError
_PyExc_RuntimeError
_PyExc_SyntaxError
_PyExc_SystemError
_PyExc_TypeError
_PyExc_ValueError
_PyExc_ZeroDivisionError
_PyFloat_FromDouble
_PyInt_AsLong
_PyInt_FromLong
_PyModule_AddObject
_PyModule_GetDict
_PyObject_CallObject
_PyObject_GetAttr
_PyObject_SetAttrString
_PyString_FromString
_PyType_Type
_Py_BuildValue
_Py_InitModule4
__Py_NoneStruct
collect2: ld returned 1 exit status
make[1]: *** [_lasso.la] Error 1
make: *** [all-recursive] Error 1

To me it looks like there is a missing library somewhere, but then I
might be wrong.

I've tried with different versions of swig 1.3.21 - 1.3.27 with the
same result.
It's the 0.6.3 version of lasso I'm trying to build.

Comments ?

-- Roland

Dec 4 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.