By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
439,986 Members | 1,583 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 439,986 IT Pros & Developers. It's quick & easy.

insert-at-cursor doesn't work

P: n/a
Hi,
I have created a window and placed a gtk.Entry inside it. I would like to
perform some tasks when the text of the entry is changed, so I have created
a connection such as this:

self.name_text=gtk.Entry()
self.name_text.connect("insert-at-cursor",self.name_text_changed,None)

Also, I have defined the function name_text_changed as follows:

def testo_cambiato(self,entry,string,data=None):

I don't receive any error while the program is run, but actually nothing
works.... I have tried to deal with other signals concerning the entry such
as activate and delete-from-cursor and they worked perfecly, so I just
don't understand what's wrong with my code.
Can anybody help?
Thanks
Marco
Jul 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.