By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,710 Members | 1,970 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,710 IT Pros & Developers. It's quick & easy.

PostegreSQL 8.0.0 Beta4 Win32

P: n/a
Hello !

The RC2 is great but :
I use an other filesystem for the data.
So I have C:\Program file\PostgreSQL... and I have F:\PostgreSQL\8.0.0-beta4\data.

In the file C:\Program Files\PostgreSQL\8.0.0-beta4\data\postgresql.conf I modify the files locations :
data_directory = 'F:/PostgreSQL/8.0.0-beta4/data'
hba_file = 'F:/PostgreSQL/8.0.0-beta4/data/pg_hba.conf'
ident_file = 'F:/PostgreSQL/8.0.0-beta4/data/pg_ident.conf'.

The file F:\PostgreSQL\8.0.0-beta4\data\pg_hba.conf contain :
# TYPE DATABASE USER CIDR-ADDRESS METHOD
local all all md5
# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 192.168.0.0/24 md5
# IPv6 local connections:
#host all all ::1/128 md5

On the localhost (192.168.0.10) with pgAdmin III (1.20 RC2),
I can't connect like localhost (localhost, beta4, pgsql-8.0.0-beta4, 5432, template1, postgres, ****)
but I can connect like an host (192.168.0.10, beta4, , 5432, template1, postgres, ****) !?
Before I split the data on an other disk I can connect as 'localhost'.
Shall I make a mistake, is it a bug ?

Some wishes :
- The win32 install let choose an alternate disk for the data ...
- The win32 install use the user variable PGDATA for the links towards configuration files (in ex. %PGDATA%\pg_hba.conf), it's more efficient when putting data on another disk.

You're doing a great job !
Best regards.

Luc ROLLAND
Nov 23 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
=?iso-8859-1?Q?Secr=E9tariat?= <et*@rolland-fr.com> writes:
The file F:\PostgreSQL\8.0.0-beta4\data\pg_hba.conf contain :
# TYPE DATABASE USER CIDR-ADDRESS METHOD
local all all md5
# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 192.168.0.0/24 md5
# IPv6 local connections:
#host all all ::1/128 md5 On the localhost (192.168.0.10) with pgAdmin III (1.20 RC2),
I can't connect like localhost (localhost, beta4, pgsql-8.0.0-beta4, =
5432, template1, postgres, ****)
but I can connect like an host (192.168.0.10, beta4, , 5432, template1, =
postgres, ****) !?
What error message do you get exactly?
Before I split the data on an other disk I can connect as 'localhost'.


I wonder whether you got confused about which set of configuration files
is being used.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #2

P: n/a
When I connect as localhost I obtain :
"Error connecting to the server: couldnot connect to server: Connection
refused (0x0000274d/10061)
Is the server running on host "127.0.0.1" and accepting
TCP/IP connections on port 5432 ?"
My pg-hba.conf seems correct (transmitted).

----- Original Message -----
From: "Tom Lane" <tg*@sss.pgh.pa.us>
To: "Secrétariat" <et*@rolland-fr.com>
Cc: <pg***********@postgresql.org>
Sent: Friday, November 19, 2004 5:02 PM
Subject: Re: [GENERAL] PostegreSQL 8.0.0 Beta4 Win32

=?iso-8859-1?Q?Secr=E9tariat?= <et*@rolland-fr.com> writes:
The file F:\PostgreSQL\8.0.0-beta4\data\pg_hba.conf contain :
# TYPE DATABASE USER CIDR-ADDRESS METHOD
local all all md5
# IPv4 local connections:
host all all 127.0.0.1/32 md5
host all all 192.168.0.0/24 md5
# IPv6 local connections:
#host all all ::1/128 md5

On the localhost (192.168.0.10) with pgAdmin III (1.20 RC2),
I can't connect like localhost (localhost, beta4, pgsql-8.0.0-beta4, =
5432, template1, postgres, ****)
but I can connect like an host (192.168.0.10, beta4, , 5432, template1, =
postgres, ****) !?


What error message do you get exactly?
Before I split the data on an other disk I can connect as 'localhost'.


I wonder whether you got confused about which set of configuration files
is being used.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #3

P: n/a
=?iso-8859-1?Q?Secr=E9tariat?= <et*@rolland-fr.com> writes:
When I connect as localhost I obtain :
"Error connecting to the server: couldnot connect to server: Connection
refused (0x0000274d/10061)
Is the server running on host "127.0.0.1" and accepting
TCP/IP connections on port 5432 ?"


"Connection refused" is a system-level error; that implies that the
postmaster isn't listening on that port at all. Check your
listen_addresses setting.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #4

P: n/a
Tom Lane wrote:
regards, tom lane

Tom,
From the content of some of your posts I gather that you are a contributor
to the PostgreSQL development effort.

I just wanted to say thanks for such a fine applications.
--
--
GreyGeek
Nov 23 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.