By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,710 Members | 1,970 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,710 IT Pros & Developers. It's quick & easy.

[pg 7.4 / Solaris 8] Could not bind socket for statistics collector

P: n/a
Hi I'm new to this list so say a quick "hello @all!"

Ok my question:
I did compile the official 7.4 sources for the solaris 8 platform and
compilation went right.
The problem occured after I started the postmaster process and
copied some data into the database using the COPY command:
waiting for postmaster to shut down...LOG: received smart shutdown
request
..LOG: shutting down
...LOG: database system is shut down
done
postmaster successfully shut down
LOG: could not bind socket for statistics collector: Cannot assign
requested address
LOG: database system was shut down at 2003-11-26 14:13:05 MET
LOG: checkpoint record is at 0/B54CB8
LOG: redo record is at 0/B54CB8; undo record is at 0/0; shutdown TRUE
LOG: next transaction ID: 546; next OID: 27748
LOG: database system is ready

I read somewhere else that the solution is to
uncomment the ::1 entry in /etc/inet/ipnodes (::1 <=> ipv6 alias to
localhost).
I just did so, and it finally worked out.
But why and by what means??? What does it mean to uncomment
the localhost entry for ipv6 in /etc/inet/ipnodes ?

Shoudn't the database run without having to modify system's internal
properties?

Regards
Mounir

Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.