470,833 Members | 1,451 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,833 developers. It's quick & easy.

sending mail from winxp os ,apache ws, php

I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error

when upload same to linux live server its working, please help me what
do i have to do for this
Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377

Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377
done

LINE 377
mail("$MYFULLEMAIL", "$MYSUBJECT", "$MYBODY", $MYHEADERS);
Jul 17 '05 #1
2 3184
Safras Ahamed wrote:
I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error


<snip>

1. www.php.net/mail
2.
http://groups.google.com/groups?selm...0rack1.php.net
--
| Just another PHP saint |
Email: rrjanbiah-at-Y!com

Jul 17 '05 #2
Safras Ahamed wrote:
I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error

when upload same to linux live server its working, please help me what
do i have to do for this
Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377

Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377
done

LINE 377
mail("$MYFULLEMAIL", "$MYSUBJECT", "$MYBODY", $MYHEADERS);


it is trying to send a mail via your LOCAL mailserver. do you HAVE a
local mailserver installed?

--
"The goal of Computer Science is to build something that will last at
least until we've finished building it." -- unknown
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Laiverd.COM | last post: by
15 posts views Thread by Sven Templin | last post: by
26 posts views Thread by Massimo Zaccarin | last post: by
3 posts views Thread by Jon Slaughter | last post: by
17 posts views Thread by William Gill | last post: by
31 posts views Thread by happyse27 | last post: by
reply views Thread by mihailmihai484 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.