By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,441 Members | 1,796 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,441 IT Pros & Developers. It's quick & easy.

sending mail from winxp os ,apache ws, php

P: n/a
I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error

when upload same to linux live server its working, please help me what
do i have to do for this
Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377

Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377
done

LINE 377
mail("$MYFULLEMAIL", "$MYSUBJECT", "$MYBODY", $MYHEADERS);
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Safras Ahamed wrote:
I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error


<snip>

1. www.php.net/mail
2.
http://groups.google.com/groups?selm...0rack1.php.net
--
| Just another PHP saint |
Email: rrjanbiah-at-Y!com

Jul 17 '05 #2

P: n/a
Safras Ahamed wrote:
I have windows xp pc and i have installed apache as a web server and
php also working fine, but when i am sending mail, its giving me
following error

when upload same to linux live server its working, please help me what
do i have to do for this
Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377

Warning: mail(): Failed to connect to mailserver at "localhost" port
25, verify your "SMTP" and "smtp_port" setting in php.ini or use
ini_set() in C:\Safras\WebHosting\netoffice.cybersoft.lk\functi ons.php
on line 377
done

LINE 377
mail("$MYFULLEMAIL", "$MYSUBJECT", "$MYBODY", $MYHEADERS);


it is trying to send a mail via your LOCAL mailserver. do you HAVE a
local mailserver installed?

--
"The goal of Computer Science is to build something that will last at
least until we've finished building it." -- unknown
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.