By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,313 Members | 1,092 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,313 IT Pros & Developers. It's quick & easy.

Jobs Not Populating Materialized Views

P: n/a
Hi All,

Sorry this may be a repost as first attempt died on me...

I have a set of 50 materialized views that are populated every morning.

However 2 of the materialized views contain no records (I know the master
does contain records).

None of the jobs are broken and all run as scheduled.

When I use DBA Studio and goto the refresh groups and manually run the job
(clicking the button 'manual refresh' or somesuch) hey presto the
snapshot's populated. It 'disappears' the next morning.

The other oddity is that when I run the SQL to generate the materialized
view in Free Toad no records are returned. However using SQL Plus the
correct results set is returned (same user in both sessions). So I assume
I've go the relevant permissions on the master tables.

Anyone got any pointers?

Regards,

Peter
Jun 27 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Pink Panther wrote:
Hi All,

Sorry this may be a repost as first attempt died on me...

I have a set of 50 materialized views that are populated every morning.

However 2 of the materialized views contain no records (I know the master
does contain records).

None of the jobs are broken and all run as scheduled.

When I use DBA Studio and goto the refresh groups and manually run the job
(clicking the button 'manual refresh' or somesuch) hey presto the
snapshot's populated. It 'disappears' the next morning.

The other oddity is that when I run the SQL to generate the materialized
view in Free Toad no records are returned. However using SQL Plus the
correct results set is returned (same user in both sessions). So I assume
I've go the relevant permissions on the master tables.

Anyone got any pointers?

Regards,

Peter
Try running the jobs manually, and see what happens then

--

Regards,
Frank van Bortel

Jun 27 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.