By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,984 Members | 1,461 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,984 IT Pros & Developers. It's quick & easy.

ASP.NET error page cannot be displayed

P: 11
Dear Techies

Im facing a strange problem. my application is available locally but NOT on LAN

My asp.net application is in C:\Inetpub\wwwroot and it has full permission for
IUSER_MYSYSNAME

My application is accessable from my local system http://locahost/webapp and but not accessable from other machines in LAN.

The error i receive when i type "http://IPADDRESS/webapp is "Page cannot be displayed"

pls. help me ASAP coz i have a dead line to launch
Apr 24 '07 #1
Share this Question
Share on Google+
10 Replies


prabunewindia
100+
P: 199
plz try with this,
creat a virtual directry in IIS.
and put ur app in it
try and inform me


Dear Techies

Im facing a strange problem. my application is available locally but NOT on LAN

My asp.net application is in C:\Inetpub\wwwroot and it has full permission for
IUSER_MYSYSNAME

My application is accessable from my local system http://locahost/webapp and but not accessable from other machines in LAN.

The error i receive when i type "http://IPADDRESS/webapp is "Page cannot be displayed"

pls. help me ASAP coz i have a dead line to launch
Apr 24 '07 #2

P: 11
Thanks 4 help

Still the same problem, ...

I have followed this steps IIS -->right click on myWebApp -->new-->virtual dir-->

in wizard Alias name="myWebApp" -->next-->browse to : C:\Inetpub\wwwroot\myWebApp -- > allow "run" and execute scripts
-->finish
Apr 24 '07 #3

prabunewindia
100+
P: 199
do u have a node in the IIS tree like Default Websites--> then right click that and try to create virtual dir.
do u have ur project in that dir created by u in iis as a Inside the tree

Thanks 4 help

Still the same problem, ...

I have followed this steps IIS -->right click on myWebApp -->new-->virtual dir-->

in wizard Alias name="myWebApp" -->next-->browse to : C:\Inetpub\wwwroot\myWebApp -- > allow "run" and execute scripts
-->finish
Apr 24 '07 #4

P: 11
thankx again

My iis tree is like this
mysysname
..Websites
.....Default web sites (rt clich->new-->virtual dir)
given dir name="myWebApp" and browse to "C:\Inetpub\wwwroot\myWebapp"

My website folder is available in "C:\Inetpub\wwwroot"

My steps to create IIS is rt? is something missing

pls. let me know with steps

Appreciated ur help
Apr 24 '07 #5

prabunewindia
100+
P: 199
ya correct.
now u plz check internet proxy settings
in internet explorer--->Tools----->Internet Options--->Connections---->Lan settings
plz check that one

thankx again

My iis tree is like this
mysysname
..Websites
.....Default web sites (rt clich->new-->virtual dir)
given dir name="myWebApp" and browse to "C:\Inetpub\wwwroot\myWebapp"

My website folder is available in "C:\Inetpub\wwwroot"

My steps to create IIS is rt? is something missing

pls. let me know with steps

Appreciated ur help
Apr 24 '07 #6

P: 11
1) In Autmatic configuration NOTHING is checked
2) Use a proxy server for your lan is CHECKED and below ISP address and port is there
3) bypass proxyserver for local addresses in UNCHECKED

thankx
Apr 24 '07 #7

Frinavale
Expert Mod 5K+
P: 9,731
I know this is going to sound lame but make sure that your Windows Firewall allows web browsers (add your web browsers to the Exceptions). Also make sure that port 80 is added to the exception list....

Better yet try turning off Windows Firewall first and see if that makes a difference before adding these things to your exception list.

Also in your IIS settings, under the default website->Properties->Directory Security make sure that everyone's able to access your website.

-Frinny
Apr 24 '07 #8

prabunewindia
100+
P: 199
check bypass proxyserver and in the virtual directry check everything, like read, write, execute etc
i am not sure, but u try like this

1) In Autmatic configuration NOTHING is checked
2) Use a proxy server for your lan is CHECKED and below ISP address and port is there
3) bypass proxyserver for local addresses in UNCHECKED

thankx
Apr 25 '07 #9

100+
P: 154
Check you IIS setting in web extensions and make sure ASP.NET is set allowed.
Apr 25 '07 #10

P: 1
To resolve this problem, use one of the following methods:
Method 1: Configure Windows Firewall to enable HTTP traffic
To configure Windows Firewall to enable HTTP traffic, follow these steps:1. Click Start, click Run, type Firewall.cpl, and then click OK.
2. On the Exceptions tab, click Add Port.
3. In the Name box, type HTTP. In the Port box, type 80.
Note This procedure enables HTTP traffic. If you also require HTTPS traffic for Secure Sockets Layer (SSL) sites, repeat these steps, but type HTTPS in the Name box, and then type 443 in the Port box.
Method 2: Configure network settings
To configure network settings, follow these steps:1. Click Start, click Run, type Firewall.cpl, and then click OK.
2. On the Advanced tab under Network Connection Settings, click your network connection, and then click Settings.
3. On the Services tab, click Web Server (HTTP), and then click OK.

Note If you must also enable HTTPS traffic for Secure Socket Layer (SSL) sites, click both Secure Web Server (HTTPS) and Web Server (HTTP).



Method 2 worked great for me :) .. hope this helps everyone
May 3 '07 #11

Post your reply

Sign in to post your reply or Sign up for a free account.