469,615 Members | 1,615 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,615 developers. It's quick & easy.

Disable linker warnings

Hi experts,
is it possible to disable linker warnings (i.e. LNK4204)?
Thanx
Mar 17 '06 #1
5 5134
> Hi experts,
is it possible to disable linker warnings (i.e. LNK4204)?
Thanx


Without the actual message and an explanation of what you are doing/have
done I cannot give you much more information than this:

http://msdn.microsoft.com/library/de...inglnk4204.asp

--

Kind regards,
Bruno van Dooren
br**********************@hotmail.com
Remove only "_nos_pam"


Mar 17 '06 #2
Hi,
I know what this warning means, I just want to disable it. (Not prevent). I
can't find command line argument to disable specific LINKER warnings
"Bruno van Dooren" <br**********************@hotmail.com> schrieb im
Newsbeitrag news:eU**************@tk2msftngp13.phx.gbl...
Hi experts,
is it possible to disable linker warnings (i.e. LNK4204)?
Thanx


Without the actual message and an explanation of what you are doing/have
done I cannot give you much more information than this:

http://msdn.microsoft.com/library/de...inglnk4204.asp

--

Kind regards,
Bruno van Dooren
br**********************@hotmail.com
Remove only "_nos_pam"

Mar 17 '06 #3
> Hi,
I know what this warning means, I just want to disable it. (Not prevent). I
can't find command line argument to disable specific LINKER warnings


As far as I know there is no general mechanism for disabling linker warnings.
The only thing you can do is to prevent them, for example by using /Zi or
/NODEFAULTLIB if appropriate.

--

Kind regards,
Bruno.
br**********************@hotmail.com
Remove only "_nos_pam"
Mar 18 '06 #4
>is it possible to disable linker warnings (i.e. LNK4204)?

I don't know if this will work or not...

Try adding the following to your linker options.

/IGNORE:4204

Dave
Mar 18 '06 #5
> >is it possible to disable linker warnings (i.e. LNK4204)?

I don't know if this will work or not...

Try adding the following to your linker options.

/IGNORE:4204

Hi,
You can give it a try, but according to this, it should not work. that
switch is not valid anymore:
http://support.microsoft.com/default...b;en-us;103717

I just did the following test: building an exe with a missing symbol. this
is only possible by using /FORCE. This will force the linker to output the
exe, but with warning LNK4088.

I was not able to suppres this warning with /IGNORE.
on the other hand, if you specify an unknown switch like /BLABLA it will be
printed in the output window with the message
LINK : warning LNK4044: unrecognized option '/BLABLA'; ignored

So one one hand the /IGNORE switch seems to be ignored, but on the other
hand it is still recognized as a known linker switch.
Perhaps one of the MVP's can dig up some more info?

--

Kind regards,
Bruno van Dooren
br**********************@hotmail.com
Remove only "_nos_pam"
Mar 18 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by Jason Heyes | last post: by
2 posts views Thread by Zarnywoop | last post: by
3 posts views Thread by Philipp Staempfli | last post: by
1 post views Thread by Codex Twin | last post: by
1 post views Thread by =?Utf-8?B?U2VhbiBDb25uZXJ5?= | last post: by
reply views Thread by devrayhaan | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.