By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,543 Members | 2,246 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,543 IT Pros & Developers. It's quick & easy.

Help - Long shot

P: n/a
I this webservice that I have developed. The webservice is only accessible
if the Windows SP2 Firewall is turned off.

How do give someone access to my local webservice and keep the firewall
running?

thanks,

Dave
Jul 21 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
You should only need to open port 80 in your Firewall.

Go to the Control Panel.
Network Connections
select "Change Windows Firewall settings"
click the Exceptions tab.
Click on "Add Port..." button.
Enter a description for the port in the name field, example "Web"
Enter 80 for the port number.
Make sure TCP option is selected.
Click on OK.

This will allow ANY computer that has access to your network the
ability to connect to port 80 (web) on your computer. This will
expose all files / applications you have configured under an IIS web
site running on port 80.

If the computer trying to access your webservice is on your local
network, then you should be all set. If you are trying to allow a
computer on the Internet to access the webservice you may need to do
some more configuration. (like setup port forwarding on your router if
you have one).

Jul 21 '05 #2

P: n/a
Nice. I got it. Thanks!

Also, I had to open my 1433 for SQL Access. I can turn it off when I done
testing.

Thank you!!

Dave
"mphacker" <mp******@sitedevelopers.com> wrote in message
news:11**********************@z14g2000cwz.googlegr oups.com...
You should only need to open port 80 in your Firewall.

Go to the Control Panel.
Network Connections
select "Change Windows Firewall settings"
click the Exceptions tab.
Click on "Add Port..." button.
Enter a description for the port in the name field, example "Web"
Enter 80 for the port number.
Make sure TCP option is selected.
Click on OK.

This will allow ANY computer that has access to your network the
ability to connect to port 80 (web) on your computer. This will
expose all files / applications you have configured under an IIS web
site running on port 80.

If the computer trying to access your webservice is on your local
network, then you should be all set. If you are trying to allow a
computer on the Internet to access the webservice you may need to do
some more configuration. (like setup port forwarding on your router if
you have one).

Jul 21 '05 #3

P: n/a
On Wed, 15 Dec 2004 13:07:38 -0600, David Pope wrote:
Nice. I got it. Thanks!

Also, I had to open my 1433 for SQL Access. I can turn it off when I done
testing.


Now why did you have to do that? It's a really bad idea.

--
FreeBSD 4.8-RELEASE i386
1:55PM up 22 days, 19:17, 1 user, load averages: 0.01, 0.01, 0.00
Jul 21 '05 #4

P: n/a
I will tell why I did it. I can't tell you what I have to do it that way.

My pocket pc app hits SQL Server on my wireless network directly. It was not
allowing me to communicate to SQL Server. I decided to open the 1433 port to
allow that to happen. SQL server is on my laptop.

Dave

"General Protection Fault" <ge*******@braids.ertw.com> wrote in message
news:slrncs15q5.frp.ge*******@braids.ertw.com...
On Wed, 15 Dec 2004 13:07:38 -0600, David Pope wrote:
Nice. I got it. Thanks!

Also, I had to open my 1433 for SQL Access. I can turn it off when I done
testing.


Now why did you have to do that? It's a really bad idea.

--
FreeBSD 4.8-RELEASE i386
1:55PM up 22 days, 19:17, 1 user, load averages: 0.01, 0.01, 0.00

Jul 21 '05 #5

P: n/a
That's odd. If you use SQL Server for CE, then it will sync with SQL Server
over port 80. You don't need to open 1433. Are you using SQL Server for
the CE?

--- Nick

"David Pope" <dp***@nospam.satx.rr.com> wrote in message
news:%2******************@TK2MSFTNGP10.phx.gbl...
I will tell why I did it. I can't tell you what I have to do it that way.

My pocket pc app hits SQL Server on my wireless network directly. It was not allowing me to communicate to SQL Server. I decided to open the 1433 port to allow that to happen. SQL server is on my laptop.

Dave

"General Protection Fault" <ge*******@braids.ertw.com> wrote in message
news:slrncs15q5.frp.ge*******@braids.ertw.com...
On Wed, 15 Dec 2004 13:07:38 -0600, David Pope wrote:
Nice. I got it. Thanks!

Also, I had to open my 1433 for SQL Access. I can turn it off when I done testing.


Now why did you have to do that? It's a really bad idea.

--
FreeBSD 4.8-RELEASE i386
1:55PM up 22 days, 19:17, 1 user, load averages: 0.01, 0.01, 0.00


Jul 21 '05 #6

P: n/a
Nah... I am using SQL Server 2000. The scanners we are using have built-in
wireless 802.11b so we can access SQL Server directly.

Dave

"Nick Malik" <ni*******@hotmail.nospam.com> wrote in message
news:uUywd.252265$HA.180339@attbi_s01...
That's odd. If you use SQL Server for CE, then it will sync with SQL
Server
over port 80. You don't need to open 1433. Are you using SQL Server for
the CE?

--- Nick

"David Pope" <dp***@nospam.satx.rr.com> wrote in message
news:%2******************@TK2MSFTNGP10.phx.gbl...
I will tell why I did it. I can't tell you what I have to do it that way.

My pocket pc app hits SQL Server on my wireless network directly. It was

not
allowing me to communicate to SQL Server. I decided to open the 1433 port

to
allow that to happen. SQL server is on my laptop.

Dave

"General Protection Fault" <ge*******@braids.ertw.com> wrote in message
news:slrncs15q5.frp.ge*******@braids.ertw.com...
> On Wed, 15 Dec 2004 13:07:38 -0600, David Pope wrote:
>> Nice. I got it. Thanks!
>>
>> Also, I had to open my 1433 for SQL Access. I can turn it off when I done >> testing.
>
> Now why did you have to do that? It's a really bad idea.
>
> --
> FreeBSD 4.8-RELEASE i386
> 1:55PM up 22 days, 19:17, 1 user, load averages: 0.01, 0.01, 0.00



Jul 21 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.