By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,278 Members | 1,544 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,278 IT Pros & Developers. It's quick & easy.

Avoid data conversion in DB2

P: n/a
Hi,

I am facing a problem whle importing the DEL files ( encoding: Unicode)
into a Unicode database.The DEL files have French Characters.I observed
that the French Character has been converted to é.
To avoid this conversion, I used MODIFIED BY CODEPAGE=1208 in the
IMPORT statement.
This worked perfectly fine.But now I do not want to modify the IMPORT
statement. Is there any way by which I can achieve this? Is there any
command line option which I can use before I import the data. Also, I
do not want to modify any DEL file encdoing, format,etc.
Iam using DB2 8.2
Thanks in advance,

Vj

Sep 26 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Have you considered using a CODEPAGE parameter on the export? You will
need to set the codepage to the codepage of the system you are using for
the IMPORT command.

Phil Sherman

bv****@gmail.com wrote:
Hi,

I am facing a problem whle importing the DEL files ( encoding: Unicode)
into a Unicode database.The DEL files have French Characters.I observed
that the French Character has been converted to é.
To avoid this conversion, I used MODIFIED BY CODEPAGE=1208 in the
IMPORT statement.
This worked perfectly fine.But now I do not want to modify the IMPORT
statement. Is there any way by which I can achieve this? Is there any
command line option which I can use before I import the data. Also, I
do not want to modify any DEL file encdoing, format,etc.
Iam using DB2 8.2
Thanks in advance,

Vj
Sep 28 '06 #2

P: n/a
Hi Phil,

Thanks for your reply.
What I did was, I set up the registry variable DB2CODEPAGE =1208 even
before I created the Unicode database using the db2set command.
This solved my problem.

Thanks once again,
Vijay
Phil Sherman wrote:
Have you considered using a CODEPAGE parameter on the export? You will
need to set the codepage to the codepage of the system you are using for
the IMPORT command.

Phil Sherman

bv****@gmail.com wrote:
Hi,

I am facing a problem whle importing the DEL files ( encoding: Unicode)
into a Unicode database.The DEL files have French Characters.I observed
that the French Character has been converted to é.
To avoid this conversion, I used MODIFIED BY CODEPAGE=1208 in the
IMPORT statement.
This worked perfectly fine.But now I do not want to modify the IMPORT
statement. Is there any way by which I can achieve this? Is there any
command line option which I can use before I import the data. Also, I
do not want to modify any DEL file encdoing, format,etc.
Iam using DB2 8.2
Thanks in advance,

Vj
Sep 29 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.