By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,223 Members | 1,371 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,223 IT Pros & Developers. It's quick & easy.

Remote Debugging Issue VS2005 (works fine with VS2003)

P: n/a
Hello ,

I fought very hard and succeed to do a remote debug from a client
with
VS2003 on XP HOME to a Server with XP PRO. This is on a Workgroup :
I
created same user/pwd with admin rights for client & Server. Also
modified the DCOM security to allow remote access to Anonymous login
and - finally- on the SERVER (client is XP home and doesn't include
secpol.msc) , changed the Security policy "network access : Sharing
and Security model for local accounts" from "guest" to "local user".
Well ..i had evry possible problems u can have and finally solved it.
......I want now to use VS2005 on my client instead of
VS2003...........
when i try to debug I have the error message ["Access is denied",
This
seems to be because the "network access : Sharing and Security model
for local accounts" security policy does not allow users to
authenticate as themselves.]
DAMNED !!! what is the difference between VS2003 and VS2005 remote
debug authentication ????
It s working correctly with 2003 and not with 2005
I configured correctly the Remote Debugger service of VS2005 with
windows authentication with my same login as before which is a member
of admin/debuger.
The STRANGEST : When i try to launch debug on the VS2005 (client) ,
the Remote debugging monitor on the server shows that my user is
connected... but i still get the error message on my VS2005 about
authentication so debug cannot proceed.
it would mean , my client connect to server with a login , the server
monitors the connection is done , but then server cannot contact
client back . ANY IDEAS ? )) thanks
I obviously cannot change this security setting in secpol.msc (as the
error message advice)because client is XP HOME.

Jun 11 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.