469,325 Members | 1,399 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,325 developers. It's quick & easy.

Process.Start executing old version of my EXE

Hi everyone,
From my WinForms app I am executing an external process. It turns out

that I have replaced the EXE of the external process with a newer
version and my WinForms app is still executing the old one. I am using
Visual Studio 2005 and programming in C#.

I have been wrecking my brains for two days and I can't find a possible
explanation. These are the things I have tried so far:
-Renaming the new EXE and, of course, referencing the new name in my
code.
-Deleted all the MUICache entries in the registry.
-Removed the EXE completely from my Visual Studio solution and added it
again.
-Deleted all the suspicious caching files of Visual Studio.
-If I xcopy my app to another computer it works.
-If I xcopy my app to another folder in the same dev computer it works
only once; in subsequent runs the old version of the EXE is called
(even with a different EXE name).

This is absolutely frustrating.

I would appreciate any input.

Thanks much!

May 3 '06 #1
0 1188

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Sorin Dolha [MCSD .NET] | last post: by
3 posts views Thread by Timothy Shih | last post: by
12 posts views Thread by Raymond Lewallen | last post: by
5 posts views Thread by Saya | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
reply views Thread by mdpf | last post: by
reply views Thread by listenups61195 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.