By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,975 Members | 1,216 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,975 IT Pros & Developers. It's quick & easy.

Intellisense disappeared!

P: n/a
GC
I have a web app with an aspx page in namespace
Abc.WebModules.Vendors.Web. I also have business classes
that are in Abc.WebModules.Vendors.Business. I have
always been able to, in the aspx class, do something like:

Business.Vendors vendor = new Business.Vendors("123");

then, typing vendor. would give me all my properties and
methods. I don't know what changed but the intellisense
stopped working. It will compile just fine but the
constructor tooltip, on declaration, no longer appears
either. I never had any XML documentation specified
either, as I read someone saying you needed this for
intellisense, but I never did.

Any ideas?
Nov 15 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Only thing I have noticed so far is that intellisense often goes away when I
try to run more than one instance of Visual Studio at one time.

"GC" <gc********@yahoo.com> wrote in message
news:04****************************@phx.gbl...
I have a web app with an aspx page in namespace
Abc.WebModules.Vendors.Web. I also have business classes
that are in Abc.WebModules.Vendors.Business. I have
always been able to, in the aspx class, do something like:

Business.Vendors vendor = new Business.Vendors("123");

then, typing vendor. would give me all my properties and
methods. I don't know what changed but the intellisense
stopped working. It will compile just fine but the
constructor tooltip, on declaration, no longer appears
either. I never had any XML documentation specified
either, as I read someone saying you needed this for
intellisense, but I never did.

Any ideas?

Nov 15 '05 #2

P: n/a
First I'd go here:

http://support.microsoft.com/search/...false&numDays=
Then I'd check the options (Options->Text Editor->All
Languages->General->Auto List Mebers)

If that does not help close all instanses of Visual Studio and delete .suo
and .user files (I think it helped me couple of times, but you never know -
it's a voodoo-kinda-stuff).
"GC" <gc********@yahoo.com> wrote in message
news:04****************************@phx.gbl...
I have a web app with an aspx page in namespace
Abc.WebModules.Vendors.Web. I also have business classes
that are in Abc.WebModules.Vendors.Business. I have
always been able to, in the aspx class, do something like:

Business.Vendors vendor = new Business.Vendors("123");

then, typing vendor. would give me all my properties and
methods. I don't know what changed but the intellisense
stopped working. It will compile just fine but the
constructor tooltip, on declaration, no longer appears
either. I never had any XML documentation specified
either, as I read someone saying you needed this for
intellisense, but I never did.

Any ideas?

Nov 15 '05 #3

P: n/a
GC
Yes it was voodoo, I resynced with sourcesafe and some
other voodoo and got it working again.

Thanks!

-----Original Message-----
First I'd go here:

http://support.microsoft.com/search/default.aspx? Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%
3DON&withinResults=&QuerySource=gASr_Query&Product =vsnet&Q
ueryc=intellisense&Query=intellisense&KeywordType= ANY&maxR
esults=25&Titles=false&numDays=

Then I'd check the options (Options->Text Editor->All
Languages->General->Auto List Mebers)

If that does not help close all instanses of Visual Studio and delete .suoand .user files (I think it helped me couple of times, but you never know -it's a voodoo-kinda-stuff).
"GC" <gc********@yahoo.com> wrote in message
news:04****************************@phx.gbl...
I have a web app with an aspx page in namespace
Abc.WebModules.Vendors.Web. I also have business classes that are in Abc.WebModules.Vendors.Business. I have
always been able to, in the aspx class, do something like:
Business.Vendors vendor = new Business.Vendors("123");

then, typing vendor. would give me all my properties and methods. I don't know what changed but the intellisense
stopped working. It will compile just fine but the
constructor tooltip, on declaration, no longer appears
either. I never had any XML documentation specified
either, as I read someone saying you needed this for
intellisense, but I never did.

Any ideas?

.

Nov 15 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.