By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,684 Members | 1,439 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,684 IT Pros & Developers. It's quick & easy.

Website with TreeView works fine in development, but crashes in a 'secure' website on server.

P: n/a
I have a website that I've developed with a treeview that works fine on the
development environment. I then copy it to our production server and the
tree view won't work.

One of the things I did was change the was the files are handled so the .Net
handles all of the requests. This was done because on the web site we have
lots of non-aspx files (.html, .doc, .xls, ...) files that we want protected
so nobody can get to them without logging in to our web page first. ( We
used to use windows authentication but that became a pain.)

So now I have it that the only pages you can get at our our login page and
my test page with the treeview. I've noticed a couple of things - if I put a
required field validator on my login page, it causes an error. The treeview
causes an error when it attempts to load. My guess is something is going on
with the extra security.

Can anbody help? It's almost like I can either have .Net handle the security
for all files/objects but now can't do javascript or the files are left open
and I can go javascript.

Any help would be appreciated.

TIA - Jeff.

Jun 10 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.