By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,214 Members | 2,038 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,214 IT Pros & Developers. It's quick & easy.

ASPNET_WP.exe 100% - Settings or Code?

P: n/a
Hello,

When we have around 40 users, the aspnet_wp jumps to 100% CPU and
all screens lag for 30 seconds or more (all on LAN). How do I tell if
this is due to settings in IIS or machine.config, or if it is due to
bad code? These are all the same page being brought up, with different
information from SQL (customer name, phone, address). This is for a
call centre environment.

I have tried fiddling with IIS and machine.config settings, but
nothing I try seems to help. 40 users on a local web server with basic
customer information pages should not do this.

HP DL380 3.4GHz single processor (same issues on 2.4GHz dual
processor)
4 GB RAM
Win2000 Server
MS SQL2000
IIS 5.0?
ASP.NET 7.1?

Thanks,
Kris Kauth

Jun 7 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
You can try changing session management. If currently you have InProc
sessions, change to OutProc and see if it helps.

--
Eliyahu Goldin,
Software Developer & Consultant
Microsoft MVP [ASP.NET]
http://msmvps.com/blogs/egoldin
http://usableasp.net
"KrisKaBob" <kr*******@gmail.comwrote in message
news:11*********************@i13g2000prf.googlegro ups.com...
Hello,

When we have around 40 users, the aspnet_wp jumps to 100% CPU and
all screens lag for 30 seconds or more (all on LAN). How do I tell if
this is due to settings in IIS or machine.config, or if it is due to
bad code? These are all the same page being brought up, with different
information from SQL (customer name, phone, address). This is for a
call centre environment.

I have tried fiddling with IIS and machine.config settings, but
nothing I try seems to help. 40 users on a local web server with basic
customer information pages should not do this.

HP DL380 3.4GHz single processor (same issues on 2.4GHz dual
processor)
4 GB RAM
Win2000 Server
MS SQL2000
IIS 5.0?
ASP.NET 7.1?

Thanks,
Kris Kauth

Jun 7 '07 #2

P: n/a
Hello KrisKaBob,

Just use Perfomance counter and profiling tools to understand what happens
and find out the spoiled code place

---
WBR, Michael Nemtsev [.NET/C# MVP].
My blog: http://spaces.live.com/laflour
Team blog: http://devkids.blogspot.com/

"The greatest danger for most of us is not that our aim is too high and we
miss it, but that it is too low and we reach it" (c) Michelangelo

KHello,
K>
KWhen we have around 40 users, the aspnet_wp jumps to 100% CPU
Kand all screens lag for 30 seconds or more (all on LAN). How do I
Ktell if this is due to settings in IIS or machine.config, or if it is
Kdue to bad code? These are all the same page being brought up, with
Kdifferent information from SQL (customer name, phone, address). This
Kis for a call centre environment.
K>
KI have tried fiddling with IIS and machine.config settings, but
Knothing I try seems to help. 40 users on a local web server with
Kbasic customer information pages should not do this.
K>
KHP DL380 3.4GHz single processor (same issues on 2.4GHz dual
Kprocessor)
K4 GB RAM
KWin2000 Server
KMS SQL2000
KIIS 5.0?
KASP.NET 7.1?
KThanks,
KKris Kauth
Jun 7 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.