469,337 Members | 5,972 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,337 developers. It's quick & easy.

Have a web site that is 'secure' but want to have a subdirectory that is not.

UJ
I have a web site that is secure by forms authentication. I've put in
changes to allow a virtual directory to be accessed by everyone but it
doesn't seem to have taken. I always end up being pushed back to my login
page.

I then took out all authentication - made it allow all and I'm still being
forced back to the my login page. Is there anything I need to do to force
the changes to happen?

Also - could somebody check my code to make sure that what I'm doing is
correct? (There is other stuff in there - I just don't bother including it.)
WebServices is a virtual directory off the root of my web site.

<configuration>
<location path="WebServices/ClientSoftware.asmx">
<system.web>
<authorization>
<allow users="*" />
</authorization>
</system.web>
</location>

<system.web>
<authentication mode="Forms">
<forms name="Login" loginUrl="/Login.aspx" protection="All"
path="/" timeout="30"></forms>
</authentication>

<authorization>
<allow users="*" />
</authorization>
</system.web>
</configuration>
Nov 20 '06 #1
1 939
UJ
Never mind. It was my own mistake.

"UJ" <fr**@nowhere.comwrote in message
news:eW**************@TK2MSFTNGP06.phx.gbl...
>I have a web site that is secure by forms authentication. I've put in
changes to allow a virtual directory to be accessed by everyone but it
doesn't seem to have taken. I always end up being pushed back to my login
page.

I then took out all authentication - made it allow all and I'm still being
forced back to the my login page. Is there anything I need to do to force
the changes to happen?

Also - could somebody check my code to make sure that what I'm doing is
correct? (There is other stuff in there - I just don't bother including
it.) WebServices is a virtual directory off the root of my web site.

<configuration>
<location path="WebServices/ClientSoftware.asmx">
<system.web>
<authorization>
<allow users="*" />
</authorization>
</system.web>
</location>

<system.web>
<authentication mode="Forms">
<forms name="Login" loginUrl="/Login.aspx" protection="All"
path="/" timeout="30"></forms>
</authentication>

<authorization>
<allow users="*" />
</authorization>
</system.web>
</configuration>


Nov 20 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

9 posts views Thread by Fred | last post: by
4 posts views Thread by gary thomson | last post: by
14 posts views Thread by Josh | last post: by
2 posts views Thread by RICHARD BROMBERG | last post: by
1 post views Thread by Corne Grotius | last post: by
reply views Thread by sberk44 | last post: by
3 posts views Thread by Mark Olbert | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by Marylou17 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.