By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,750 Members | 1,471 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,750 IT Pros & Developers. It's quick & easy.

URGENT - Very Puzzled - IIS Authentication

P: n/a
Hi All

My appologies for the URGENT shout but I need to get this sorted by 06:00
GMT otherwise I am going to have 150 screaming intranet users moaning at me.

Win 2k Server
ASP.NET 2

I have just deployed our shiny new ASP.NET 2 Intranet app and want to use
Integrated windows authentication at IIS level with "windows" authentication
in web.config.

I have put the tick in "Integrated Windows Authentication" in the directory
security tab of the website in IIS and taken the tick out of the "Anonymous
Access"

As part of our Group Policy all client XP PCs have thier IE home page set to
http://intranet.ourdomain.com which is the URL to our intranet.

The win2k intranet server is called sguk-web1 with an IP of 192.168.0.9

Users log onto the local area network as normal using thier windows logon,
authenticating against active directory.

The problem I am getting is as follows:
When a user opens up IE which takes them to the URL stated they get a log on
dialogue to enter thier network username and password again, which I don't
want to happen I just want it to go straight to the intranet and have
windows handle all authentication and authorization in the background.

To puzzle matters further if the user types in http://sguk-web1 then
everything works as it should do and windows does everything in the
backgroud.

But if the user types in http://192.168.0.9 then we get the same issue as if
they had gone to the URL http://intranet.ourdomain.com .

Any suggestions?

Best Regards
Bren

--
Why do I climb mountains? Simple! because they are there
www.3peakschallenge.co.uk
Aug 24 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Given that it's an intranet app, and that all your clients are within your
network, instruct your users to go to http://sguk-web1 to enter the intranet.

While you sort things out regarding the naming issue, that will cover your *ss.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Bren" <mwrote in message news:uX**************@TK2MSFTNGP03.phx.gbl...
Hi All

My appologies for the URGENT shout but I need to get this sorted by 06:00 GMT otherwise I am going
to have 150 screaming intranet users moaning at me.

Win 2k Server
ASP.NET 2

I have just deployed our shiny new ASP.NET 2 Intranet app and want to use Integrated windows
authentication at IIS level with "windows" authentication in web.config.

I have put the tick in "Integrated Windows Authentication" in the directory security tab of the
website in IIS and taken the tick out of the "Anonymous Access"

As part of our Group Policy all client XP PCs have thier IE home page set to
http://intranet.ourdomain.com which is the URL to our intranet.

The win2k intranet server is called sguk-web1 with an IP of 192.168.0.9

Users log onto the local area network as normal using thier windows logon, authenticating against
active directory.

The problem I am getting is as follows:
When a user opens up IE which takes them to the URL stated they get a log on dialogue to enter
thier network username and password again, which I don't want to happen I just want it to go
straight to the intranet and have windows handle all authentication and authorization in the
background.

To puzzle matters further if the user types in http://sguk-web1 then everything works as it should
do and windows does everything in the backgroud.

But if the user types in http://192.168.0.9 then we get the same issue as if they had gone to the
URL http://intranet.ourdomain.com .

Any suggestions?

Aug 24 '06 #2

P: n/a
And if you read his post it says:
>As part of our Group Policy all client XP PCs have thier IE home
page set to
>http://intranet.ourdomain.com which is the URL to our intranet.
so when they open their browser it will go there by default!

Juan T. Llibre wrote:
Given that it's an intranet app, and that all your clients are within your
network, instruct your users to go to http://sguk-web1 to enter the intranet.

While you sort things out regarding the naming issue, that will cover your *ss.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Bren" <mwrote in message news:uX**************@TK2MSFTNGP03.phx.gbl...
>Hi All

My appologies for the URGENT shout but I need to get this sorted by 06:00 GMT otherwise I am going
to have 150 screaming intranet users moaning at me.

Win 2k Server
ASP.NET 2

I have just deployed our shiny new ASP.NET 2 Intranet app and want to use Integrated windows
authentication at IIS level with "windows" authentication in web.config.

I have put the tick in "Integrated Windows Authentication" in the directory security tab of the
website in IIS and taken the tick out of the "Anonymous Access"

As part of our Group Policy all client XP PCs have thier IE home page set to
http://intranet.ourdomain.com which is the URL to our intranet.

The win2k intranet server is called sguk-web1 with an IP of 192.168.0.9

Users log onto the local area network as normal using thier windows logon, authenticating against
active directory.

The problem I am getting is as follows:
When a user opens up IE which takes them to the URL stated they get a log on dialogue to enter
thier network username and password again, which I don't want to happen I just want it to go
straight to the intranet and have windows handle all authentication and authorization in the
background.

To puzzle matters further if the user types in http://sguk-web1 then everything works as it should
do and windows does everything in the backgroud.

But if the user types in http://192.168.0.9 then we get the same issue as if they had gone to the
URL http://intranet.ourdomain.com .

Any suggestions?

Aug 24 '06 #3

P: n/a
Cheers for your replies guys.

I have sorted it now.
It was an issue with the security settings within IE
IE settingsInternet OptionsSecurity TabTrusted Sites iconCustom
level
button, scroll all the way to bottom of list,

User Authentication
-Login
X Automatic logon with current username and password

The network group policy was so locked down IE was allways trying to log in
anonymously.

Just changed group policy IE settings and problem solved.

Rgds
Bren
Aug 24 '06 #4

P: n/a
Ah, yes! That vaunted Trusted Sites trick again! Darn Internet Exploder!
Thanks for reminding us.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"Bren" wrote:
Cheers for your replies guys.

I have sorted it now.
It was an issue with the security settings within IE
IE settingsInternet OptionsSecurity TabTrusted Sites iconCustom
level
button, scroll all the way to bottom of list,

User Authentication
-Login
X Automatic logon with current username and password

The network group policy was so locked down IE was allways trying to log in
anonymously.

Just changed group policy IE settings and problem solved.

Rgds
Bren
Aug 24 '06 #5

P: n/a
re:
And if you read his post it says:
....
so when they open their browser it will go there by default!
Of course. That's why I suggested that the Group Policies be changed!

:-)

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Kevin Jones" <kj**********@develop.comwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
And if you read his post it says:
As part of our Group Policy all client XP PCs have thier IE home
page set to
http://intranet.ourdomain.com which is the URL to our intranet.

so when they open their browser it will go there by default!

Juan T. Llibre wrote:
>Given that it's an intranet app, and that all your clients are within your
network, instruct your users to go to http://sguk-web1 to enter the intranet.

While you sort things out regarding the naming issue, that will cover your *ss.
Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Bren" <mwrote in message news:uX**************@TK2MSFTNGP03.phx.gbl...
>>Hi All

My appologies for the URGENT shout but I need to get this sorted by 06:00 GMT otherwise I am
going to have 150 screaming intranet users moaning at me.

Win 2k Server
ASP.NET 2

I have just deployed our shiny new ASP.NET 2 Intranet app and want to use Integrated windows
authentication at IIS level with "windows" authentication in web.config.

I have put the tick in "Integrated Windows Authentication" in the directory security tab of the
website in IIS and taken the tick out of the "Anonymous Access"

As part of our Group Policy all client XP PCs have thier IE home page set to
http://intranet.ourdomain.com which is the URL to our intranet.

The win2k intranet server is called sguk-web1 with an IP of 192.168.0.9

Users log onto the local area network as normal using thier windows logon, authenticating
against active directory.

The problem I am getting is as follows:
When a user opens up IE which takes them to the URL stated they get a log on dialogue to enter
thier network username and password again, which I don't want to happen I just want it to go
straight to the intranet and have windows handle all authentication and authorization in the
background.

To puzzle matters further if the user types in http://sguk-web1 then everything works as it
should do and windows does everything in the backgroud.

But if the user types in http://192.168.0.9 then we get the same issue as if they had gone to
the URL http://intranet.ourdomain.com .

Any suggestions?
Aug 24 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.