By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,866 Members | 1,704 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,866 IT Pros & Developers. It's quick & easy.

asp.net worker does not load up ...SIGH

P: n/a
ok... so i restarted my server and i get a
"Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.
Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur. "
on the application i'm trying to access.

I check the application log and find:
"aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker
process account has insufficient rights to read the .NET Framework files.
Please ensure that the .NET Framework is correctly
installed and that the ACLs on the installation directory allow access to
the configured account."

This is the first time i've seen this so i checked the newsgroups and such
and found topics that related and tried changing the permissions, made sure
that the aspnet worker had full permission, tried the system acct, tried an
impersonated acct. Then i tried aspnet_regiis -i as others said that worked
and it didn't resolve anything. Then i checked the log again and it failed
installing... ergh...
here are the error msgs:
"Unable to read the performance counter strings of the 009 language ID. The
Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET_1.1.4322 failed. The
Error code is DWORD 0 of the Record Data. "
"Unable to read the performance counter strings of the 009 language ID. The
Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET failed. The Error
code is DWORD 0 of the Record Data. "

i've tried all day to get it back up and running. I'm sick of the aspnet
worker dying on me all the time... he obviously is working himself to death
or a weak worker... [this is actually the first time it's died on the server,
but it died more than it's share on my 3 other machines which is really
upsetting actually...sigh]

but any tips to get it back up and running would be much appreciated...
thanks in advance!
Nov 19 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Sammy,

I don't have any exact ideas, but if you think it's a permission thing, you
can TEMPORARILY give ASP.NET account administrator access and see if that
fixes the problem. If it does, you know you're on the correct path. Don't
leave it like that though, figure it out, and remove admin access from that
account.

Steve

"sammy" <sa*@nospam.nospam> wrote in message
news:08**********************************@microsof t.com...
ok... so i restarted my server and i get a
"Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.
Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur. " on the application i'm trying to access.

I check the application log and find:
"aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker
process account has insufficient rights to read the .NET Framework files.
Please ensure that the .NET Framework is correctly
installed and that the ACLs on the installation directory allow access to
the configured account."

This is the first time i've seen this so i checked the newsgroups and such
and found topics that related and tried changing the permissions, made sure that the aspnet worker had full permission, tried the system acct, tried an impersonated acct. Then i tried aspnet_regiis -i as others said that worked and it didn't resolve anything. Then i checked the log again and it failed
installing... ergh...
here are the error msgs:
"Unable to read the performance counter strings of the 009 language ID. The Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET_1.1.4322 failed. The Error code is DWORD 0 of the Record Data. "
"Unable to read the performance counter strings of the 009 language ID. The Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET failed. The Error
code is DWORD 0 of the Record Data. "

i've tried all day to get it back up and running. I'm sick of the aspnet
worker dying on me all the time... he obviously is working himself to death or a weak worker... [this is actually the first time it's died on the server, but it died more than it's share on my 3 other machines which is really
upsetting actually...sigh]

but any tips to get it back up and running would be much appreciated...
thanks in advance!

Nov 19 '05 #2

P: n/a
Hi Steve,

Thanks for your reply. I've tried giving the asp.net account admin access
and have also tried creating another acct and using that and giving it admin
access.

I installed MDAC 2.8 the other day as well. And this all happened when I
reset the machine. Any ideas?

thanks

"Steve Lutz" wrote:
Sammy,

I don't have any exact ideas, but if you think it's a permission thing, you
can TEMPORARILY give ASP.NET account administrator access and see if that
fixes the problem. If it does, you know you're on the correct path. Don't
leave it like that though, figure it out, and remove admin access from that
account.

Steve

"sammy" <sa*@nospam.nospam> wrote in message
news:08**********************************@microsof t.com...
ok... so i restarted my server and i get a
"Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web

browser
to retry your request.
Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web

server.
Please review this log entry to discover what caused this error to occur.

"
on the application i'm trying to access.

I check the application log and find:
"aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker
process account has insufficient rights to read the .NET Framework files.
Please ensure that the .NET Framework is correctly
installed and that the ACLs on the installation directory allow access to
the configured account."

This is the first time i've seen this so i checked the newsgroups and such
and found topics that related and tried changing the permissions, made

sure
that the aspnet worker had full permission, tried the system acct, tried

an
impersonated acct. Then i tried aspnet_regiis -i as others said that

worked
and it didn't resolve anything. Then i checked the log again and it failed
installing... ergh...
here are the error msgs:
"Unable to read the performance counter strings of the 009 language ID.

The
Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET_1.1.4322 failed.

The
Error code is DWORD 0 of the Record Data. "
"Unable to read the performance counter strings of the 009 language ID.

The
Win32 status returned by the call is in the Record Data as DWORD 0. "
"Installing the performance counter strings for ASP.NET failed. The Error
code is DWORD 0 of the Record Data. "

i've tried all day to get it back up and running. I'm sick of the aspnet
worker dying on me all the time... he obviously is working himself to

death
or a weak worker... [this is actually the first time it's died on the

server,
but it died more than it's share on my 3 other machines which is really
upsetting actually...sigh]

but any tips to get it back up and running would be much appreciated...
thanks in advance!


Nov 19 '05 #3

P: n/a
Hi Sammy,

Don't worry, let's have a troubleshoot step by step. What's your server's
OS version and have you installed other patch or do any particular
configuration changes on the server?
And is the problem only occur in your particular asp.net project or all the
asp.net applcation on your server no longer works ( you can try creating a
new simple one to verify this).

Based on my experience, there're some former issues regarding on the
similiar symptom. Is your server a Domain Controller , if so, this may
caused by the asp.net 's process account be changed to another one other
than the default machine\aspnet on win2k server.

Also, since the error report is concerned with the process account , have
you done any "RESET PASSWORD" operation on those local accounts on your
machine, since the asp.net's default process account aspnet is computer
controled password, manually reset it may cause error.

In addition, if your machien is 2k server and does use the machine\aspnet
as the process account, you can try removing the aspnet account and
recreate it via the following means:

1. Open computer management and delete the ASPNET user account
2. Open a command prompt and run the following two commands:
a. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -ua
b. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -i
3. Ensure that the <processModel> had the userName attribute set to run as
machine.

HTH. If you have any other findings, please feel free to post here also.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #4

P: n/a
Hi Steven,

thanks for the quick response!
i'm running wink2kserver sp4 and all of my application files are located on
a file server. so i have a local machine user named aspnet and a user on the
file server named aspnet w/ the same pw.

I tried doing the steps that you suggested below but i'm still getting the
same error.
When I first started setting this up, I changed the local machine's acct pw
to match the file server's pw but that didn't seem to cause problems
before... hmmm... Maybe it hasn't mattered because I haven't reset the
machine till now? Not sure, but that's all the info I can think of...

let me know what you suggest next.
thanks!
sam
"Steven Cheng[MSFT]" wrote:
Hi Sammy,

Don't worry, let's have a troubleshoot step by step. What's your server's
OS version and have you installed other patch or do any particular
configuration changes on the server?
And is the problem only occur in your particular asp.net project or all the
asp.net applcation on your server no longer works ( you can try creating a
new simple one to verify this).

Based on my experience, there're some former issues regarding on the
similiar symptom. Is your server a Domain Controller , if so, this may
caused by the asp.net 's process account be changed to another one other
than the default machine\aspnet on win2k server.

Also, since the error report is concerned with the process account , have
you done any "RESET PASSWORD" operation on those local accounts on your
machine, since the asp.net's default process account aspnet is computer
controled password, manually reset it may cause error.

In addition, if your machien is 2k server and does use the machine\aspnet
as the process account, you can try removing the aspnet account and
recreate it via the following means:

1. Open computer management and delete the ASPNET user account
2. Open a command prompt and run the following two commands:
a. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -ua
b. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -i
3. Ensure that the <processModel> had the userName attribute set to run as
machine.

HTH. If you have any other findings, please feel free to post here also.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #5

P: n/a
Hi Sam,

Thanks for your followup. Well, now I've got that since your application
put the files and contents on a remote shared folder , you change your
local aspnet account's password to mapping the remote file server's local
aspnet account.

Since by default the <processModel> element in machine,.config is set as
userName="Machine" password="AutoGenerate", have you changed that to the
correct one after manually control the aspnet account's password. '

Also, I think you can first try recreating a new simple asp.net project on
your win2k server machine and just use local file system(not a remote
shared folder) to see whether it can work. Or alternatively, you can first
try make a simple asp.net web page be able to run on your server (you can
try put a simple page on the IIS default site's root folder to test).

In addition, if you haven't try reset the aspnet account as I mentioned
previously, you can try reset it back and then change back the processModel
in machine.config to userName="Machine" password="AutoGenerate" and then
restart to server to let the change take effect.

Hope helps. IF there is any other findings, please feel free to post here.
Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #6

P: n/a
Hi Steven,

my asp_net worker won't start due to permissions issues...
i haven't been able to get it started back up again and i'll try changin the
config file and get back to you...

thanks again!
"Steven Cheng[MSFT]" wrote:
Hi Sam,

Thanks for your followup. Well, now I've got that since your application
put the files and contents on a remote shared folder , you change your
local aspnet account's password to mapping the remote file server's local
aspnet account.

Since by default the <processModel> element in machine,.config is set as
userName="Machine" password="AutoGenerate", have you changed that to the
correct one after manually control the aspnet account's password. '

Also, I think you can first try recreating a new simple asp.net project on
your win2k server machine and just use local file system(not a remote
shared folder) to see whether it can work. Or alternatively, you can first
try make a simple asp.net web page be able to run on your server (you can
try put a simple page on the IIS default site's root folder to test).

In addition, if you haven't try reset the aspnet account as I mentioned
previously, you can try reset it back and then change back the processModel
in machine.config to userName="Machine" password="AutoGenerate" and then
restart to server to let the change take effect.

Hope helps. IF there is any other findings, please feel free to post here.
Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #7

P: n/a
Hi Sam,

Any further progress on this or have you got the problem fixed?

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

Nov 19 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.