By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,373 Members | 1,763 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,373 IT Pros & Developers. It's quick & easy.

ASPNET_SETREG runs on XP, not 2000

P: n/a
I have a webservice up and running locally on my dev machine (XP) using
impersonate like so:

Line 5: <identity impersonate="true"
Line 6:
userName="registry:HKLM\SOFTWARE\Security\identity \ASPNET_SETREG,userName"
Line 7:
password="registry:HKLM\SOFTWARE\Security\identity \ASPNET_SETREG,password"/>

The webservice comes up fine on there, but when I moved it to a server
running 2000, I get this error :
Parser Error Message: Error reading the password from the registry.

I have read several articles, and tried many things, including granting
EVERYONE read access as a test, and I still get this error. What am I doing
wrong here?

I ran ASPNET_SETREG.exe on the server, saw the registry entry, granted
ASPNET read access (later giving it to EVERYONE), but nothing seems to work.

Thanks in advance for any help.

Nov 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.