468,754 Members | 1,417 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,754 developers. It's quick & easy.

Passing unicode characters in forms

I have as issue I am finding hard to research.

I use a stored proecdure in SQL 2000 to provide search capability for
our database of news stories and articles. Being an international
magazine publisher we use foreign characters extensively.

When searching for words (I am using Full Text Indexing and using the
CONTAINSTABLE method) with accented characters such as Møller (Second
character is Alt+0248) the form receives back Møller

When this is passed to the stored procedure it only searches for the
single character M

Is it possible to pass the unicode characters to SQL properly using a
built in function or do I have to recreate the string manually searching
for unicode characters as passed by the browser and recreate them as
proper unicode characters?

M@t :o)

Nov 17 '05 #1
5 3828
Hi,

Use the N perfix :

Select From TestTable where myfield = N'....'
http://support.microsoft.com/default...port.microsoft.
com:80/support/kb/articles/Q239/5/30.ASP&NoWebContent=1

Natty Gur, CTO
Dao2Com Ltd.
28th Baruch Hirsch st. Bnei-Brak
Israel , 51114

Phone Numbers:
Office: +972-(0)3-5786668
Fax: +972-(0)3-5703475
Mobile: +972-(0)58-888377

Know the overall picture
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #2


It's not the passing of data in unicode format that's the problem but
the encoding that is applied at the web site - as in my original post
you can see that I am getting out "M&#248ller" when I enter "Møller" - I
need to be able to turn the &#248 into a unicode char before I pass it.

Also as I am using a stored procedure I don't believe I can prefix the
paramter name with N to indicate that it is Unicode - I have to set the
paramter up as nvarchar(x) in the stored procedure instead.

M@t :o)

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #3


Just to confirm for anyone reading on the web - my problem is in
receiving "M&#248ller" from the web form. I just realised that web
sites are translating the &#248 in my original post to a slashed "O"

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 17 '05 #4
Hello Matt,

I think you could try add encoding in web.config file.

Also, please save the aspx file with encoding info. To achieve it, please save the file in VS.NET IDE and...:
-----------------------------------------
Advanced Save Options Dialog Box
Use this dialog box to specify non-default language encoding options and to register your line-ending character preferences
for an open file. To access this dialog box, open a file in Visual Studio and choose Advanced Save Options on the File
menu.

Encoding
Use this list box to apply a new language encoding scheme to the target file.
Line Endings
When creating a file intended for distribution to users of different operating systems, you can select one of the following
carriage return or line feed options to ensure consistent document formatting.
----------------------------------

Hope it helps.

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: Matthew Thompson <ma**************@lrfairplay.com>
!References: <er**************@TK2MSFTNGP09.phx.gbl>
!X-Newsreader: AspNNTP 1.50 (ActionJackson.com)
!Subject: Re: Passing unicode characters in forms
!Mime-Version: 1.0
!Content-Type: text/plain; charset="us-ascii"
!Content-Transfer-Encoding: 7bit
!Message-ID: <#q**************@TK2MSFTNGP12.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!Date: Wed, 30 Jul 2003 03:53:33 -0700
!NNTP-Posting-Host: actionjackson133.dsl.frii.net 216.17.147.133
!Lines: 1
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163298
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!
!
!Just to confirm for anyone reading on the web - my problem is in
!receiving "M&amp;#248ller" from the web form. I just realised that web
!sites are translating the &amp;#248 in my original post to a slashed "O"
!
!*** Sent via Developersdex http://www.developersdex.com ***
!Don't just participate in USENET...get rewarded for it!
!
Nov 17 '05 #5
Hello Matt,

I saw a similar post in the group and reply you there. Here is the link for your reference. Thanks.

http://groups.google.com/groups?hl=e...23ynVDHA.2248%
40TK2MSFTNGP10.phx.gbl&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26q%
3DPassing%2Bunicode%2Bcharacters%2Bin%2Bforms%26sa %3DN%26tab%3Dwg

Best regards,
Yanhong Huang
Microsoft Online Partner Support

Get Secure! - www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
!From: Matthew Thompson <ma**************@lrfairplay.com>
!References: <er**************@TK2MSFTNGP09.phx.gbl>
!X-Newsreader: AspNNTP 1.50 (ActionJackson.com)
!Subject: Re: Passing unicode characters in forms
!Mime-Version: 1.0
!Content-Type: text/plain; charset="us-ascii"
!Content-Transfer-Encoding: 7bit
!Message-ID: <eI**************@TK2MSFTNGP09.phx.gbl>
!Newsgroups: microsoft.public.dotnet.framework.aspnet
!Date: Wed, 30 Jul 2003 03:43:51 -0700
!NNTP-Posting-Host: actionjackson133.dsl.frii.net 216.17.147.133
!Lines: 1
!Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
!Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.framework.aspnet:163295
!X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
!
!
!
!It's not the passing of data in unicode format that's the problem but
!the encoding that is applied at the web site - as in my original post
!you can see that I am getting out "M&#248ller" when I enter "Møller" - I
!need to be able to turn the &#248 into a unicode char before I pass it.
!
!Also as I am using a stored procedure I don't believe I can prefix the
!paramter name with N to indicate that it is Unicode - I have to set the
!paramter up as nvarchar(x) in the stored procedure instead.
!
!M@t :o)
!
!*** Sent via Developersdex http://www.developersdex.com ***
!Don't just participate in USENET...get rewarded for it!
!
Nov 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Borko | last post: by
3 posts views Thread by Mohammad-Reza | last post: by
9 posts views Thread by R.Kaiser | last post: by
13 posts views Thread by Kelvin Moss | last post: by
1 post views Thread by CARIGAR | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.