By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,426 Members | 1,689 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,426 IT Pros & Developers. It's quick & easy.

Maximum connections to http server

P: n/a
By default, the machine.config contains following information:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="2"/>
</connectionManagement>
</system.net>

This limits the number of connections to web server to 2. For example, if
you want to write code to post xml to a web server using HttpWebRequest
object, the call to GetResponse() will be blocked except for first 2
threads. All other threads will enter GetResponse method as previous threads
are done.

Tthe msdn documentation says that if you want increase this number for any
http server, you need to modify this configuration in either machine.config
or app confic or policy config file as below:

<system.net>
.......
<connectionManagement>
<add address="www.abc.com" maxconnection="15"/>
</connectionManagement>
</system.net>

I have a web application that is deployed on internal web server. So I
modified it as following:

<system.net>
.......
<connectionManagement>
<add address="mymachine" maxconnection="15"/>
</connectionManagement>
</system.net>

This did not work at all. I also tried the machine in active directory
network name mymachine.ab.cde. It did not work either.

But when I modified as below, it worked:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="15"/>
</connectionManagement>
</system.net>

But I do not want to apply this for every server. So can someone tell what
am I doing wrong?

Thanks.
Raghu/..
Nov 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Raghu,

Have you tried using the IP address instead of name?
--
Ray Dixon - Microsoft MVP
ra*@NOSPAM.greeble.com
(remove NOSPAM. from my e-mail address for a direct reply)
"Raghu Rudra" <Ra*********@qcsi.com> wrote in message
news:%2****************@TK2MSFTNGP11.phx.gbl...
By default, the machine.config contains following information:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="2"/>
</connectionManagement>
</system.net>

This limits the number of connections to web server to 2. For example, if
you want to write code to post xml to a web server using HttpWebRequest
object, the call to GetResponse() will be blocked except for first 2
threads. All other threads will enter GetResponse method as previous threads are done.

Tthe msdn documentation says that if you want increase this number for any
http server, you need to modify this configuration in either machine.config or app confic or policy config file as below:

<system.net>
.......
<connectionManagement>
<add address="www.abc.com" maxconnection="15"/>
</connectionManagement>
</system.net>

I have a web application that is deployed on internal web server. So I
modified it as following:

<system.net>
.......
<connectionManagement>
<add address="mymachine" maxconnection="15"/>
</connectionManagement>
</system.net>

This did not work at all. I also tried the machine in active directory
network name mymachine.ab.cde. It did not work either.

But when I modified as below, it worked:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="15"/>
</connectionManagement>
</system.net>

But I do not want to apply this for every server. So can someone tell what
am I doing wrong?

Thanks.
Raghu/..

Nov 17 '05 #2

P: n/a
I did not the first time. Now I did. It is still not working the it is
supposed to.

"Ray Dixon [MVP]" <ra*@NOSPAM.greeble.com> wrote in message
news:e3*************@TK2MSFTNGP12.phx.gbl...
Hi Raghu,

Have you tried using the IP address instead of name?
--
Ray Dixon - Microsoft MVP
ra*@NOSPAM.greeble.com
(remove NOSPAM. from my e-mail address for a direct reply)
"Raghu Rudra" <Ra*********@qcsi.com> wrote in message
news:%2****************@TK2MSFTNGP11.phx.gbl...
By default, the machine.config contains following information:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="2"/>
</connectionManagement>
</system.net>

This limits the number of connections to web server to 2. For example, if you want to write code to post xml to a web server using HttpWebRequest
object, the call to GetResponse() will be blocked except for first 2
threads. All other threads will enter GetResponse method as previous

threads
are done.

Tthe msdn documentation says that if you want increase this number for any http server, you need to modify this configuration in either

machine.config
or app confic or policy config file as below:

<system.net>
.......
<connectionManagement>
<add address="www.abc.com" maxconnection="15"/>
</connectionManagement>
</system.net>

I have a web application that is deployed on internal web server. So I
modified it as following:

<system.net>
.......
<connectionManagement>
<add address="mymachine" maxconnection="15"/>
</connectionManagement>
</system.net>

This did not work at all. I also tried the machine in active directory
network name mymachine.ab.cde. It did not work either.

But when I modified as below, it worked:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="15"/>
</connectionManagement>
</system.net>

But I do not want to apply this for every server. So can someone tell what am I doing wrong?

Thanks.
Raghu/..


Nov 17 '05 #3

P: n/a
It depends on what your platform is.
Windows XP and Windows 2000 professional have a hard coded limited of
10 "simultaneous" connections because they are not "Server" OS's. This
is usually sufficient for development purposes but not for production
servers and/ or load testing.
I "think" that the setting you are referring to in machine.config
refers to the number of connections per request. Like when you hit a
webpage and it begins downloading images for that page.. it can use up
to two connections by default to download these to the client. Someone
can correct me if I'm wrong.

Darren Mombourquette

"Raghu Rudra" <Ra*********@qcsi.com> wrote in message news:<u8**************@TK2MSFTNGP12.phx.gbl>...
I did not the first time. Now I did. It is still not working the it is
supposed to.

"Ray Dixon [MVP]" <ra*@NOSPAM.greeble.com> wrote in message
news:e3*************@TK2MSFTNGP12.phx.gbl...
Hi Raghu,

Have you tried using the IP address instead of name?
--
Ray Dixon - Microsoft MVP
ra*@NOSPAM.greeble.com
(remove NOSPAM. from my e-mail address for a direct reply)
"Raghu Rudra" <Ra*********@qcsi.com> wrote in message
news:%2****************@TK2MSFTNGP11.phx.gbl...
By default, the machine.config contains following information:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="2"/>
</connectionManagement>
</system.net>

This limits the number of connections to web server to 2. For example, if you want to write code to post xml to a web server using HttpWebRequest
object, the call to GetResponse() will be blocked except for first 2
threads. All other threads will enter GetResponse method as previous threads are done.

Tthe msdn documentation says that if you want increase this number for any http server, you need to modify this configuration in either machine.config or app confic or policy config file as below:

<system.net>
.......
<connectionManagement>
<add address="www.abc.com" maxconnection="15"/>
</connectionManagement>
</system.net>

I have a web application that is deployed on internal web server. So I
modified it as following:

<system.net>
.......
<connectionManagement>
<add address="mymachine" maxconnection="15"/>
</connectionManagement>
</system.net>

This did not work at all. I also tried the machine in active directory
network name mymachine.ab.cde. It did not work either.

But when I modified as below, it worked:

<system.net>
.......
<connectionManagement>
<add address="*" maxconnection="15"/>
</connectionManagement>
</system.net>

But I do not want to apply this for every server. So can someone tell what am I doing wrong?

Thanks.
Raghu/..


Nov 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.