By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,573 Members | 904 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,573 IT Pros & Developers. It's quick & easy.

Access 2007: importing text date

P: n/a
In Access 2007, I have successfully imported a text file with fixed width
fields. However the import did not correctly interpret a date. In the text
file the date field had no delimiter, was just MMDDYYYY. This column
appears empty in my table.

It doesn't seem like this is a hard thing to do. Any suggestions?

Marianne
Oct 15 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Mimi wrote:
In Access 2007, I have successfully imported a text file with fixed width
fields. However the import did not correctly interpret a date. In the text
file the date field had no delimiter, was just MMDDYYYY. This column
appears empty in my table.

It doesn't seem like this is a hard thing to do. Any suggestions?
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

When you import the text file use the Advanced button on the import
dialog box. This will display the import specification dialog box.
There are boxes that contain the date month/day/year delimiters - delete
anything in those boxes. Check the CheckBox for "Leading Zeros." This
will tell Access to read dates like 1/1/08 as 010108. Check the
CheckBox for "4-digit years." In the Fields specifications (in the
lower section of the specification dialog box) make sure the date field
has a Date/Time data type.
--
MGFoster:::mgf00 <atearthlink <decimal-pointnet
Oakland, CA (USA)
** Respond only to this newsgroup. I DO NOT respond to emails **

-----BEGIN PGP SIGNATURE-----
Version: PGP for Personal Privacy 5.0
Charset: noconv

iQA/AwUBSPaGMoechKqOuFEgEQJTigCfaw3UzAphQ3VieQR4hbNSN/VbNyEAoO5b
t1jL2sMNwb+7B/pQofkvrKVK
=rXSI
-----END PGP SIGNATURE-----
Oct 16 '08 #2

P: n/a

"MGFoster" <me@privacy.comwrote in message
news:W8******************************@earthlink.co m...
Mimi wrote:
>In Access 2007, I have successfully imported a text file with fixed width
fields. However the import did not correctly interpret a date. In the
text file the date field had no delimiter, was just MMDDYYYY. This
column appears empty in my table.

It doesn't seem like this is a hard thing to do. Any suggestions?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

When you import the text file use the Advanced button on the import
dialog box. This will display the import specification dialog box.
There are boxes that contain the date month/day/year delimiters - delete
anything in those boxes. Check the CheckBox for "Leading Zeros." This
will tell Access to read dates like 1/1/08 as 010108. Check the
CheckBox for "4-digit years." In the Fields specifications (in the
lower section of the specification dialog box) make sure the date field
has a Date/Time data type.
--
Thanks for your response.

But it didn't seem to work. I don't quite understand your last sentence. In
the Import specification box, the Fields specifications don't have any type
specification, just a field name, start column and width. (and a check box.)
There is a blank field to the left and two blank fields (columns) to the
right. The corresponding field in the recipient table is Date/Time.

Thanks again for your help.

Marianne
Oct 16 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.