By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,853 Members | 941 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,853 IT Pros & Developers. It's quick & easy.

Accessing .mdb data from a remote computer on a non asp application

P: n/a
Hi,

I have developed a small application that is using a MSAccess DB.
the problem is that it was developed on a machine where the
application and the DB are both located.
now it needs to be change that the application will be able to run on
any other machine (using \\ syntax on the run command- not a problem)
using the DB located on a static-different machine.

for this purpose I need to create a Remote Connection from my
application to the machine that holdes the DB.

I have searched for code example over the net and the only solution I
have fount which fits to my application is changing the connection
string from:
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data
Source=c:\\Cutomers.mdb";
to:
Provider=MS Remote;Remote Server=noa-second;Remote
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\\Cutomers.mdb;"
("noa-second" is the machine where the MDB file is located)

when I use the second one (with the remote) I get the error: "business
object cannot be created"

adding http:// to the Remote Server sends error "count not connect to
server" what make sense because it is not an asp application (it is a
windows form one).

trying to leave the original connectionstring and change the Source to
\\noa-second\c$...(or c:) doesn't hellp also and shows the error "not
a valid file name" and after looking in the error details I saw that c:
\ have been added to the start of the link I wrote.

Please Help me...

Aug 29 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
On Wed, 29 Aug 2007 05:54:35 -0700, Noy B <no*****@gmail.comwrote:

That "Remote server" path is wrong. Check out connectionstrings.com

Note: you cannot connect to an Access db using the HTTP protocol. But
\\server\share\backend.mdb is just fine.

-Tom.

>Hi,

I have developed a small application that is using a MSAccess DB.
the problem is that it was developed on a machine where the
application and the DB are both located.
now it needs to be change that the application will be able to run on
any other machine (using \\ syntax on the run command- not a problem)
using the DB located on a static-different machine.

for this purpose I need to create a Remote Connection from my
application to the machine that holdes the DB.

I have searched for code example over the net and the only solution I
have fount which fits to my application is changing the connection
string from:
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data
Source=c:\\Cutomers.mdb";
to:
Provider=MS Remote;Remote Server=noa-second;Remote
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\\Cutomers.mdb;"
("noa-second" is the machine where the MDB file is located)

when I use the second one (with the remote) I get the error: "business
object cannot be created"

adding http:// to the Remote Server sends error "count not connect to
server" what make sense because it is not an asp application (it is a
windows form one).

trying to leave the original connectionstring and change the Source to
\\noa-second\c$...(or c:) doesn't hellp also and shows the error "not
a valid file name" and after looking in the error details I saw that c:
\ have been added to the start of the link I wrote.

Please Help me...
Aug 29 '07 #2

P: n/a
On Aug 29, 4:54 pm, Tom van Stiphout <no.spam.tom7...@cox.netwrote:
On Wed, 29 Aug 2007 05:54:35 -0700, Noy B <noyb...@gmail.comwrote:

That "Remote server" path is wrong. Check out connectionstrings.com

Note: you cannot connect to an Access db using the HTTP protocol. But
\\server\share\backend.mdb is just fine.

-Tom.
Hi,
I have developed a small application that is using a MSAccess DB.
the problem is that it was developed on a machine where the
application and the DB are both located.
now it needs to be change that the application will be able to run on
any other machine (using \\ syntax on the run command- not a problem)
using the DB located on a static-different machine.
for this purpose I need to create a Remote Connection from my
application to the machine that holdes the DB.
I have searched for code example over the net and the only solution I
have fount which fits to my application is changing the connection
string from:
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data
Source=c:\\Cutomers.mdb";
to:
Provider=MS Remote;Remote Server=noa-second;Remote
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\\Cutomers.mdb;"
("noa-second" is the machine where the MDB file is located)
when I use the second one (with the remote) I get the error: "business
object cannot be created"
adding http:// to the Remote Server sends error "count not connect to
server" what make sense because it is not an asp application (it is a
windows form one).
trying to leave the original connectionstring and change the Source to
\\noa-second\c$...(or c:) doesn't hellp also and shows the error "not
a valid file name" and after looking in the error details I saw that c:
\ have been added to the start of the link I wrote.
Please Help me...- Hide quoted text -

- Show quoted text -

\\server\share\backend.mdb have throws me the error not a valid file
name. for some reason it is adding "c:\\" at the begining. have you
faced this problem befaure?

about the site connectionstring.com I couldn't find anything wrong
with my Remote Server. is there any thing you can point out?

Thanks!

Aug 29 '07 #3

P: n/a
Is your "remote server" on your LAN? If not, where is it?

Maybe Tom was too gentle, or too restrictive, when he said can't use
http://protocol ...

Open your database in Design View, and from the Database Window, Tools |
Database Utilities | Linked Table Manager. If you can't browse and find the
shared folder and file, you can't link the Tables; if you can, Bob's your
uncle, as they say back in the British Isles. Accessing databases via the
Internet to link Tables is NOT supported.

In the vast majority of cases, accessing a split database even via a WAN is
'way too slow. A client application to tables in server DBs across a WAN
will usually work nicely, because of the difference in the way Server and
File-Server databases process data.

Larry Linson
Microsoft Access MVP
"Noy B" <no*****@gmail.comwrote in message
news:11**********************@50g2000hsm.googlegro ups.com...
On Aug 29, 4:54 pm, Tom van Stiphout <no.spam.tom7...@cox.netwrote:
>On Wed, 29 Aug 2007 05:54:35 -0700, Noy B <noyb...@gmail.comwrote:

That "Remote server" path is wrong. Check out connectionstrings.com

Note: you cannot connect to an Access db using the HTTP protocol. But
\\server\share\backend.mdb is just fine.

-Tom.
>Hi,
>I have developed a small application that is using a MSAccess DB.
the problem is that it was developed on a machine where the
application and the DB are both located.
now it needs to be change that the application will be able to run on
any other machine (using \\ syntax on the run command- not a problem)
using the DB located on a static-different machine.
>for this purpose I need to create a Remote Connection from my
application to the machine that holdes the DB.
>I have searched for code example over the net and the only solution I
have fount which fits to my application is changing the connection
string from:
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data
Source=c:\\Cutomers.mdb";
to:
Provider=MS Remote;Remote Server=noa-second;Remote
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\\Cutomers.mdb;"
("noa-second" is the machine where the MDB file is located)
>when I use the second one (with the remote) I get the error: "business
object cannot be created"
>adding http:// to the Remote Server sends error "count not connect to
server" what make sense because it is not an asp application (it is a
windows form one).
>trying to leave the original connectionstring and change the Source to
\\noa-second\c$...(or c:) doesn't hellp also and shows the error "not
a valid file name" and after looking in the error details I saw that c:
\ have been added to the start of the link I wrote.
>Please Help me...- Hide quoted text -

- Show quoted text -


\\server\share\backend.mdb have throws me the error not a valid file
name. for some reason it is adding "c:\\" at the begining. have you
faced this problem befaure?

about the site connectionstring.com I couldn't find anything wrong
with my Remote Server. is there any thing you can point out?

Thanks!

Aug 30 '07 #4

P: n/a
On Aug 30, 6:21 am, "Larry Linson" <boun...@localhost.notwrote:
Is your "remote server" on your LAN? If not, where is it?

Maybe Tom was too gentle, or too restrictive, when he said can't usehttp://protocol...

Open your database in Design View, and from the Database Window, Tools |
Database Utilities | Linked Table Manager. If you can't browse and find the
shared folder and file, you can't link the Tables; if you can, Bob's your
uncle, as they say back in the British Isles. Accessing databases via the
Internet to link Tables is NOT supported.

In the vast majority of cases, accessing a split database even via a WAN is
'way too slow. A client application to tables in server DBs across a WAN
will usually work nicely, because of the difference in the way Server and
File-Server databases process data.

Larry Linson
Microsoft Access MVP

"Noy B" <noyb...@gmail.comwrote in message

news:11**********************@50g2000hsm.googlegro ups.com...
On Aug 29, 4:54 pm, Tom van Stiphout <no.spam.tom7...@cox.netwrote:
On Wed, 29 Aug 2007 05:54:35 -0700, Noy B <noyb...@gmail.comwrote:
That "Remote server" path is wrong. Check out connectionstrings.com
Note: you cannot connect to an Access db using the HTTP protocol. But
\\server\share\backend.mdb is just fine.
-Tom.
Hi,
I have developed a small application that is using a MSAccess DB.
the problem is that it was developed on a machine where the
application and the DB are both located.
now it needs to be change that the application will be able to run on
any other machine (using \\ syntax on the run command- not a problem)
using the DB located on a static-different machine.
for this purpose I need to create a Remote Connection from my
application to the machine that holdes the DB.
I have searched for code example over the net and the only solution I
have fount which fits to my application is changing the connection
string from:
string connectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data
Source=c:\\Cutomers.mdb";
to:
Provider=MS Remote;Remote Server=noa-second;Remote
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\\Cutomers.mdb;"
("noa-second" is the machine where the MDB file is located)
when I use the second one (with the remote) I get the error: "business
object cannot be created"
adding http:// to the Remote Server sends error "count not connect to
server" what make sense because it is not an asp application (it is a
windows form one).
trying to leave the original connectionstring and change the Source to
\\noa-second\c$...(or c:) doesn't hellp also and shows the error "not
a valid file name" and after looking in the error details I saw that c:
\ have been added to the start of the link I wrote.
Please Help me...- Hide quoted text -
- Show quoted text -
\\server\share\backend.mdb have throws me the error not a valid file
name. for some reason it is adding "c:\\" at the begining. have you
faced this problem befaure?
about the site connectionstring.com I couldn't find anything wrong
with my Remote Server. is there any thing you can point out?
Thanks!- Hide quoted text -

- Show quoted text -
Thanks for you'r answer.
all machines involved in this process are on the same network.
Now, the application is been "programmed" on the same machine the .mdb
is placed on. therefor, the first problem is to recognize the .mdb
file other then c:\.... meaning, i need to create a connectionString
that will allow me to contact the same .mdb file that currently is
located on the same machine i'm programming on with remote connection.

thanks,

noy

Aug 30 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.