471,337 Members | 829 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,337 software developers and data experts.

Function gives error in WinXP but in Win2k works fine in Access2003 (Ungent)

Hi All,

I am currently facing a crutial problem in Access2003 in Windows XP on just 3 PCs, the Application throws some of the errors specified below :

1. Error Number : 3075 Function is not available in expressions in query expression 'Format([Field_Name],"$#,##0.00")' .

2. On Click Error : The expression you entered refers to an object that is closed or doesn't exist.

3. On Click Error : Function is not available in expressions in query expression
'First(IIf(Ucase$([Field_Name)="A",1,2))'

I have already checked for the following points:

1. Installed and Re-installed the Setup.
2. Check for all OCX & DLL are there at location.
3. No Missing Reference exists.
4. Latest version of MDAC is already installed.
5. Jet Engine is already Updated.
6. XP SP2 is installed.

Also checked the system having same configuration with the working one.

As per my observation the error is in the Functions used in the Query called on the click event.

What could be the more causes for the error.

Please help its urgent.

Thanks in adavnce
Deependra
Mar 7 '07 #1
2 1580
ADezii
8,826 Expert 8TB
Hi All,

I am currently facing a crutial problem in Access2003 in Windows XP on just 3 PCs, the Application throws some of the errors specified below :

1. Error Number : 3075 Function is not available in expressions in query expression 'Format([Field_Name],"$#,##0.00")' .

2. On Click Error : The expression you entered refers to an object that is closed or doesn't exist.

3. On Click Error : Function is not available in expressions in query expression
'First(IIf(Ucase$([Field_Name)="A",1,2))'

I have already checked for the following points:

1. Installed and Re-installed the Setup.
2. Check for all OCX & DLL are there at location.
3. No Missing Reference exists.
4. Latest version of MDAC is already installed.
5. Jet Engine is already Updated.
6. XP SP2 is installed.

Also checked the system having same configuration with the working one.

As per my observation the error is in the Functions used in the Query called on the click event.

What could be the more causes for the error.

Please help its urgent.

Thanks in adavnce
Deependra
Kindly post the actual code.
Mar 7 '07 #2
NeoPa
32,405 Expert Mod 16PB
I suspect the SQL for the query that calls the function may prove helpful too. Can you include that in your post too please.
Mar 8 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

14 posts views Thread by David W. Fenton | last post: by
1 post views Thread by Dave | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.