By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,098 Members | 989 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,098 IT Pros & Developers. It's quick & easy.

Strange behavior in a continuous forms subform

P: n/a
I've asked this question before but over a month later I still don't have an
answer. A few people did try to help and I am thankful, but I really didn't
get the problem solved. I'll try to ask the question another way.

I have a main form for collecting grades for students' activities. Inside
the form is a subform which displays four fields: studentID, lName, fName,
and score. The first three fields are only to identify the student and will
not be editable from this form. This form is only for entering the scores
for an activity, such as an exam or some other assignment. So the first
three fields are disabled and locked. The "score" field is enabled and
unlocked so a score can be entered. When the form opens, the score field of
the first record has the focus. I enter a score and press Enter or Tab and
the focus moves to the second record just as it should. Then something
strange happens. The focus bounces back to the first record! I press Enter
or Tab again and it goes to the second record and stays there. I enter the
second score and tab to the third record, etc., and it always works fine
from the second record till the end of the recordset. Only the first record
causes this odd behavior and only when I'm changing the value in this text
box. Other attempts to answer my question included asking me if I had a
requery in there somewhere and the answer is "No." I do not have any
requeries in there anywhere. Could it have anything to do with Tab Stops or
Tab Order? I created another subform and inserted it into this form and
removed the old one and the problem went away. So I disabled and locked the
first three fields and fiddled with the tab orders and tab stops and the
same problem came back. I'll do this again, paying particular attention to
when the problem comes back. Maybe I can identify the cause. Maybe it's
the fact that only one field is enabled? So I tried enabling and unlocking
all the fields but that didn't take the problem away. I tried putting the
tabs back to the original and that didn't help. I'm pretty confused. Any
other ideas? Thanks.

Rich Hollenbeck

Nov 13 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.