473,740 Members | 6,250 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

MySQLdb installation error

I log into the machine remotely. How do I check the Mac OSX version
number under command line? Thanks.
hiaips rosedb0 at gmail.com
Wed Aug 16 01:23:10 CEST 2006

* Previous message: MySQLdb installation error
* Next message: What would be the best way to run python client in
the background
* Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Yi Xing wrote:

I met the following error when I tried to install MySQLdb. I had no
problem installing numarray, Numeric, Rpy, etc. Does anyone know
what's the problem? Thanks!

running install
running build
running build_py
creating build
creating build/lib.darwin-7.9.0-Power_Macintosh-2.4
copying _mysql_exceptio ns.py ->
creating build/lib.darwin-7.9.0-Power_Macintosh-2.4/MySQLdb
copying MySQLdb/__init__.py ->
copying MySQLdb/converters.py ->
copying MySQLdb/connections.py ->
copying MySQLdb/cursors.py ->
copying MySQLdb/release.py ->
copying MySQLdb/times.py ->
creating build/lib.darwin-7.9.0-Power_Macintosh-2.4/MySQLdb/constants
copying MySQLdb/constants/__init__.py ->
copying MySQLdb/constants/CR.py ->
copying MySQLdb/constants/FIELD_TYPE.py ->
copying MySQLdb/constants/ER.py ->
copying MySQLdb/constants/FLAG.py ->
copying MySQLdb/constants/REFRESH.py ->
copying MySQLdb/constants/CLIENT.py ->
running build_ext
building '_mysql' extension
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4
gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
-mno-fused-madd -fno-common -dynamic -DNDEBUG -g -O3 -Wall
-Wstrict-prototypes -I/usr/include/mysql
-I/Library/Frameworks/Python.framewor k/Versions/2.4/include/python2.4
-c _mysql.c -o build/temp.darwin-7.9.0-Power_Macintosh-2.4/_mysql.o
-fno-omit-frame-pointer -arch i386 -arch ppc -pipe
-Dversion_info=" (1,2,1,'final', 2)" -D__version__="1 .2.1_p2"
gcc: cannot read specs file for arch `i386'
error: command 'gcc' failed with exit status 1
What version of OSX are you running?

Aug 17 '06 #1
1 3376

What I'm getting at is that it looks like one of these arch flags needs
to be removed, as a previous poster said. I remember having a similar
issue with an arch flag when installing some Python module (don't
remember whether it was MySQLdb or not), and I fixed it by installing
the Universal SDK that comes with XCode on OS 10.4. If this is not an
option for you (and it sounds as though it may not be), you might also
try editing the Makefile to remove the flag corresponding to the
architecture that does not match your system.

"uname -a" should tell you which architecture you're on as well as what
version of the OS you're running.

Aug 17 '06 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Peter Nikolaidis | last post by:
Greetings, I am attempting to get MySQLdb 0.9.2 installed on Mac OS 10.2 with a Fink distribution of Python 2.2.2. I have seen only a few posts on the subject, some of them relate to "conflicting header files," but I don't know what to do about conflicting header files, or where I would find them, and once I found them, which ones to remove. I have compiled MySQL 4.1 and installed into /usr/local/mysql, but since have moved to a Fink...
by: Stephen Roderick | last post by:
Getting weird error, and I was wondering if anyone had any suggestions. My system appears to satisfy all MySQLdb prerequisities in terms of python, mysql, etc. Also, phpMyAdmin works fine with mysql, leading me to believe that my installation of MySQLdb is at fault. Any ideas? TIA For file test1.py (for appropriate values of user and passwd, and database location exists)
by: praba kar | last post by:
Dear All After installation of Mysql-Python Interface. I try to import MySQLdb but I got below error How to correct this error. regards Praba >>> import MySQLdb Traceback (most recent call last):
by: Steve | last post by:
Darwin steve.local 8.3.0 Darwin Kernel Version 8.3.0: Mon Oct 3 20:04:04 PDT 2005; root:xnu-792.6.22.obj~2/RELEASE_PPC Power Macintosh powerpc MacOSX 10.4.3 mysql Ver 14.7 Distrib 4.1.14, for apple-darwin8.2.0 (powerpc) using readline 4.3 runing the software gives me steve:~/MySQL-python-1.2.0 steve$ python setup.py build
by: Fred | last post by:
I hope someone can help me with the below problem... Thanks, Fred My enviroment: -------------------------- Slackware Linux 10.2 Python 2.4.2 MySql version 4.1.14
by: Yi Xing | last post by:
Hi, I met the following error when I tried to install MySQLdb. I had no problem installing numarray, Numeric, Rpy, etc. Does anyone know what's the problem? Thanks! running install running build running build_py creating build
by: antonyliu2002 | last post by:
I downloaded MySQL-python-1.2.1 from SourceForge and installed it on a Mandrake system (Mandrake Linux 9.2 3.3.1-2mdk on linux2). The installation was successful. The gcc version is 3.3. My Python version is 2.4.2. When I import MySQLdb, I get an error which says that __pure_virtual is an undefined symbol. Look:
by: Gerard M | last post by:
Hi guys I have a big problem with this wrapper im using Ubuntu 7.04 and I want to install python-MySQLdb, I used synaptics and it is installed, but when I try to do and I get this error: Traceback (most recent call last): File "<stdin>", line 1, in <module> File "MySQLdb/__init__.py", line 19, in <module> import _mysql ImportError: No module named _mysql
by: martinnorth | last post by:
Hi, I am running Python and MySQL on Ubuntu and have installed MySQLdb. If I try to import MySQLdb I get the following error: ActivePython (ActiveState Software Inc.) based on Python 2.5.2 (r252:60911, Mar 27 2008, 16:42:08) on linux2 Type "help", "copyright", "credits" or "license" for more information. Traceback (most recent call last):
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, weíll explore What is ONU, What Is Router, ONU & Routerís main usage, and What is the difference between ONU and Router. Letís take a closer look ! Part I. Meaning of...
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.