471,073 Members | 1,402 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,073 software developers and data experts.

Error linking libpq into client program

I'm trying to build a client program to access a database using the libpq
interface on MacOS X 10.3.3 using CodeWarrior 9. PostgreSQL is at version
7.4.2.

It compiles ok, but I get a link error. I have linked to libpq.a, because I got
different errors before I did that. Here is the error I'm getting right now:

Link Error: undefined: '@_1' (code)
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 23 '05 #1
2 2222
on 5/5/04, Jim Crate <jc****@deepskytech.com> wrote:
I'm trying to build a client program to access a database using the libpq
interface on MacOS X 10.3.3 using CodeWarrior 9. PostgreSQL is at version
7.4.2.

It compiles ok, but I get a link error. I have linked to libpq.a, becauseI gotdifferent errors before I did that. Here is the error I'm getting right now:

Link Error: undefined: '@_1' (code)
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a


As an update, I moved the project to Xcode (which uses gcc), and it compiles
and links just fine. I guess this was just a problem with CW? Does this work
with other compilers?

Jim Crate
Deep Sky Technologies, Inc.

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #2
on 5/5/04, Jim Crate <jc****@deepskytech.com> wrote:
I'm trying to build a client program to access a database using the libpq
interface on MacOS X 10.3.3 using CodeWarrior 9. PostgreSQL is at version
7.4.2.

It compiles ok, but I get a link error. I have linked to libpq.a, becauseI gotdifferent errors before I did that. Here is the error I'm getting right now:

Link Error: undefined: '@_1' (code)
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a
Referenced from 'pqSetenvPoll' in libpq.a


As an update, I moved the project to Xcode (which uses gcc), and it compiles
and links just fine. I guess this was just a problem with CW? Does this work
with other compilers?

Jim Crate
Deep Sky Technologies, Inc.

---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Phil Campaigne | last post: by
1 post views Thread by Laszlo | last post: by
reply views Thread by Jim Crate | last post: by
1 post views Thread by Robert Fitzpatrick | last post: by
2 posts views Thread by alltest1 | last post: by
2 posts views Thread by Luis P. Mendes | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.