470,867 Members | 1,807 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,867 developers. It's quick & easy.

register_globals

I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?

Thank you,
Samuel

Aug 1 '06 #1
5 4420
"Samuel Shulman" <sa************@ntlworld.comwrote:
I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?
This error message comes from some software written in PHP that you are
trying to run; it is not part of PHP. Maybe the software isn't testing
properly? Maybe you have disabled register_globals in httpd.conf or
..htaccess?

miguel
--
Photos from 40 countries on 5 continents: http://travel.u.nu
Latest photos: Malaysia; Thailand; Singapore; Spain; Morocco
Airports of the world: http://airport.u.nu
Aug 1 '06 #2

Samuel Shulman wrote:
I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?

Thank you,
Samuel
No, never enable register_globals. Bad, Bad, Bad. Something else is
wrong in your script/server. What script are you trying to run? Is it a
custom made one? if so then you should know where that error is coming
from. Else, the script your are using is screwed...

Aug 1 '06 #3
Thank you for your response,

This is the script that probably caused the problem:

if (function_exists('ini_get')) {
ini_get('register_globals') or exit('FATAL ERROR: register_globals is
disabled in php.ini, please enable it!');
}

This script is part of a big website that already running and I only want to
keep it working

What can I do?

Samuel

"dawnerd" <da*****@gmail.comwrote in message
news:11**********************@i42g2000cwa.googlegr oups.com...
>
Samuel Shulman wrote:
>I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?

Thank you,
Samuel

No, never enable register_globals. Bad, Bad, Bad. Something else is
wrong in your script/server. What script are you trying to run? Is it a
custom made one? if so then you should know where that error is coming
from. Else, the script your are using is screwed...

Aug 1 '06 #4
Samuel Shulman wrote:
Thank you for your response,

This is the script that probably caused the problem:

if (function_exists('ini_get')) {
ini_get('register_globals') or exit('FATAL ERROR: register_globals is
disabled in php.ini, please enable it!');
}

This script is part of a big website that already running and I only want to
keep it working

What can I do?

Samuel

"dawnerd" <da*****@gmail.comwrote in message
news:11**********************@i42g2000cwa.googlegr oups.com...
>>Samuel Shulman wrote:
>>>I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?

Thank you,
Samuel

No, never enable register_globals. Bad, Bad, Bad. Something else is
wrong in your script/server. What script are you trying to run? Is it a
custom made one? if so then you should know where that error is coming
from. Else, the script your are using is screwed...


You didn't say which version of PHP you're running, but turning it on in
the php.ini file should work - unless it's overridden, as Miguel
indicated. Be sure to check the syntax of your php.ini very carefully.

However - you NEED to fix your code so that it doesn't require
register_globals to be on. It's a huge security hole, and may be
completely disabled in future versions of PHP.

So you can fix it now, or run with the security risk and have to change
it later, anyway. Better to do it now.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Aug 1 '06 #5
On Tue, 01 Aug 2006 19:04:48 GMT, "Samuel Shulman"
<sa************@ntlworld.comwrote:
>I keep getting the
'FATAL ERROR: register_globals is disabled in php.ini, please enable it!'
error

I changes that settings and I still get this error

What should I do next?
Find the script that is insisting register_globals is turned on, and either
upgrade it to a version that doesn't require register_globals, or stop using
it.

register_globals isn't inherently a security risk, but it does turn certain
sloppy programming practices into severe security risks - and it is itself a
sloppy programming practice, and strongly deprecated many versions of PHP ago.

--
Andy Hassall :: an**@andyh.co.uk :: http://www.andyh.co.uk
http://www.andyhsoftware.co.uk/space :: disk and FTP usage analysis tool
Aug 1 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Frank | last post: by
10 posts views Thread by John | last post: by
8 posts views Thread by lian | last post: by
2 posts views Thread by Phil Latio | last post: by
15 posts views Thread by news | last post: by
6 posts views Thread by peter | last post: by
17 posts views Thread by peter | last post: by
12 posts views Thread by Dave | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.