470,614 Members | 1,396 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,614 developers. It's quick & easy.

"shared memory realm not available" on Orc9i, W2k

Hello,

When I try to connect to my Oracle instance on the W2K server that it
is installed on, using SQLPLUS (ie, SQLPLUS user/password@instance), I
get:

ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist

If I try again at the "Enter user-name:" prompt with "user/password",
I then get:

ERROR:
ORA-12560: TNS:Protocol adapter error
On the server, the OracleOraHome92TNSListener service and the
OracleServiceInstance service are both running.

The TNSNAMES.ORA is pointing to the localhost and port 1521 (and TCP),
and the Listener.ora seems to be OK because it has TCP as a protocol,
the machinename as the host, and 1521 as the port. It also has a
second address as IPC with a key of EXTPROC0.

I didn't have a variable set for the oracle_sid, so I set this
manually (set oracle_sid=instance from a commandline) but there was no
change on that.
Oracle is 9.2.0.1.0, and it is running W2K service pack 4.

Not being an expert, I am not really sure what else to check so any
hints would be most welcome. I hope I haven't missed any vital piece
of info!

Cheers
Jul 19 '05 #1
8 12193
The CQMMAN wrote:
Hello,

When I try to connect to my Oracle instance on the W2K server that it
is installed on, using SQLPLUS (ie, SQLPLUS user/password@instance), I
get:

ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist

If I try again at the "Enter user-name:" prompt with "user/password",
I then get:

ERROR:
ORA-12560: TNS:Protocol adapter error
On the server, the OracleOraHome92TNSListener service and the
OracleServiceInstance service are both running.

The TNSNAMES.ORA is pointing to the localhost and port 1521 (and TCP),
and the Listener.ora seems to be OK because it has TCP as a protocol,
the machinename as the host, and 1521 as the port. It also has a
second address as IPC with a key of EXTPROC0.

I didn't have a variable set for the oracle_sid, so I set this
manually (set oracle_sid=instance from a commandline) but there was no
change on that.
Oracle is 9.2.0.1.0, and it is running W2K service pack 4.

Not being an expert, I am not really sure what else to check so any
hints would be most welcome. I hope I haven't missed any vital piece
of info!

Cheers


Try some real values; "instance" is not a valid SID name.
Check your services; it's the one called oracleserviceXXXX; the XXXX
is your SID.
Then issue -in a command line window-
set oracle_sid=XXXX and retry your start operation.

Alternatively, start the oracleserviceXXXX; if set up correctly,
it will also mount and open the database. Id oracleserviceXXXX
is already started, but you still get the 1034, follow procedure
as above.
--

Regards,
Frank van Bortel

Jul 19 '05 #2
Frank van Bortel <fv********@netscape.net> wrote in message news:<cb**********@news1.tilbu1.nb.home.nl>...
Try some real values; "instance" is not a valid SID name.
Check your services; it's the one called oracleserviceXXXX; the XXXX
is your SID.
Then issue -in a command line window-
set oracle_sid=XXXX and retry your start operation.

Alternatively, start the oracleserviceXXXX; if set up correctly,
it will also mount and open the database. Id oracleserviceXXXX
is already started, but you still get the 1034, follow procedure
as above.

Ah, I did.. Sorry, just wrote "instance" instead of the actual
instance name..

Anyway it looks like it is up. Basically the database is not set to
start automatically so I needed to connect with SQLPLUS and the /nolog
switch and was then able to start it, and then connect.

Cheers
Jul 19 '05 #3
Frank van Bortel <fv********@netscape.net> wrote in message news:<cb**********@news1.tilbu1.nb.home.nl>...
Try some real values; "instance" is not a valid SID name.
Check your services; it's the one called oracleserviceXXXX; the XXXX
is your SID.
Then issue -in a command line window-
set oracle_sid=XXXX and retry your start operation.

Alternatively, start the oracleserviceXXXX; if set up correctly,
it will also mount and open the database. Id oracleserviceXXXX
is already started, but you still get the 1034, follow procedure
as above.

Actually, if I can tack on to the end of this thread with another
question, I can now connect when logged on as the domain admin (the
user who installed Oracle), but when I logon as a domain user with
local admin rights on that W2K box, I get "insufficient privileges".

The "domain user/local admin" account is a member of the ORA_DBA group
on the local server, and in fact, I have created a domain group called
"Oracle admins", added the "domain user/local admin" account to it,
and added the group to the ORA_DBA group.

I have also looked in SQLNET.ORA and the line says:

SQLNET.AUTHENTICATION_SERVICES = (NTS)

So, not sure what else I need to change to get that W2KAD account to
be able to start the database.

BTW, the Oracle services are running using the localsystem account...

Cheers
Jul 19 '05 #4
You have a basic set up problem.

Assuming you are trying to access a database for learning or just getting
started, the easiest way to get around this is to look at the Step By Step
instructions on how to install and access available at

http://otn.oracle.com/obe

Follow the links for Oracle9i database, and look at Installation tutorial

/Hans
Jul 19 '05 #5
cq****@yahoo.co.uk (The CQMMAN) wrote in message news:<65**************************@posting.google. com>...
Frank van Bortel <fv********@netscape.net> wrote in message news:<cb**********@news1.tilbu1.nb.home.nl>...
Try some real values; "instance" is not a valid SID name.
Check your services; it's the one called oracleserviceXXXX; the XXXX
is your SID.
Then issue -in a command line window-
set oracle_sid=XXXX and retry your start operation.

Alternatively, start the oracleserviceXXXX; if set up correctly,
it will also mount and open the database. Id oracleserviceXXXX
is already started, but you still get the 1034, follow procedure
as above.

Actually, if I can tack on to the end of this thread with another
question, I can now connect when logged on as the domain admin (the
user who installed Oracle), but when I logon as a domain user with
local admin rights on that W2K box, I get "insufficient privileges".

The "domain user/local admin" account is a member of the ORA_DBA group
on the local server, and in fact, I have created a domain group called
"Oracle admins", added the "domain user/local admin" account to it,
and added the group to the ORA_DBA group.

I have also looked in SQLNET.ORA and the line says:

SQLNET.AUTHENTICATION_SERVICES = (NTS)

So, not sure what else I need to change to get that W2KAD account to
be able to start the database.

BTW, the Oracle services are running using the localsystem account...

Cheers


Where in the installation instructions does Oracle recommend you
should be connected as the *domain* administrator when installing?
Answer: nowhere! You should install Oracle as *local* administrator

Sybrand Bakker
Senior Oracle DBA
Jul 19 '05 #6
Hi,
Have you change the password of windows administrator after oracle
installation.If yes then please follow the following steps.
1). In control panal windows services
2). open the property of "OracleServiceORCL"
3). click on log on account tab
4). Clock on This account redio button
5). Mention the username and password you have change
6). Restart the services again or restart the computer
7). Try to connect through sqlplus

Enjoy.

regards,
Oracle sysman
Jul 19 '05 #7
sy******@yahoo.com wrote in message news:<a1**************************@posting.google. com>...
cq****@yahoo.co.uk (The CQMMAN) wrote in message news:<65**************************@posting.google. com>...
Frank van Bortel <fv********@netscape.net> wrote in message news:<cb**********@news1.tilbu1.nb.home.nl>...
Try some real values; "instance" is not a valid SID name.
Check your services; it's the one called oracleserviceXXXX; the XXXX
is your SID.
Then issue -in a command line window-
set oracle_sid=XXXX and retry your start operation.

Alternatively, start the oracleserviceXXXX; if set up correctly,
it will also mount and open the database. Id oracleserviceXXXX
is already started, but you still get the 1034, follow procedure
as above.

Actually, if I can tack on to the end of this thread with another
question, I can now connect when logged on as the domain admin (the
user who installed Oracle), but when I logon as a domain user with
local admin rights on that W2K box, I get "insufficient privileges".

The "domain user/local admin" account is a member of the ORA_DBA group
on the local server, and in fact, I have created a domain group called
"Oracle admins", added the "domain user/local admin" account to it,
and added the group to the ORA_DBA group.

I have also looked in SQLNET.ORA and the line says:

SQLNET.AUTHENTICATION_SERVICES = (NTS)

So, not sure what else I need to change to get that W2KAD account to
be able to start the database.

BTW, the Oracle services are running using the localsystem account...

Cheers


Where in the installation instructions does Oracle recommend you
should be connected as the *domain* administrator when installing?
Answer: nowhere! You should install Oracle as *local* administrator

Sybrand Bakker
Senior Oracle DBA


I never said anything about the installation instructions recommending
that I should be connected as the domain admin to do the install.

My question was, if I want to start the Oracle database while logged
on with a different account, what do I need to do to get it to work? I
thought I have been quite thorough in what I tried/checked, but I must
be missing something somewhere.
Jul 19 '05 #8
or**********@yahoo.com (Sajid Noor) wrote in message news:<78**************************@posting.google. com>...
Hi,
Have you change the password of windows administrator after oracle
installation.If yes then please follow the following steps.
1). In control panal windows services
2). open the property of "OracleServiceORCL"
3). click on log on account tab
4). Clock on This account redio button
5). Mention the username and password you have change
6). Restart the services again or restart the computer
7). Try to connect through sqlplus

Enjoy.

regards,
Oracle sysman


Thanks, but it is not quite the same problem. The services are running
fine, but when I connect with SQLPLUS, I cannot start the database
connected as SYSDBA unless I am logged on to the server with a
specific W2KAD account. So something is not quite right somewhere.

Thanks
Jul 19 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Berthold Hoellmann | last post: by
2 posts views Thread by Jenna Schmidt | last post: by
6 posts views Thread by Ross | last post: by
7 posts views Thread by Carsten H. Pedersen | last post: by
reply views Thread by Morgan Cheng | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.