471,092 Members | 1,720 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,092 software developers and data experts.

Unable to compile in TOAD (purchased version)

Hi,

I'm getting the message "NO CREATE [OR REPLACE] statement found to
execute" in the procedure edit window of TOAD (v7.3.0.0). The code
COMPILED last night and now this morning I get this message. There are
no syntax errors since we edited and compiled the stored procedure
successfully on the free Toad.

I can copy-paste the exact code to a SQL window and it compiled. Also,
selecting the stored. proc. from the Schema Browser list compiles with
no problems.

This is a problem when trying to debug. A co-worker having the same
version had it happened to him also at the same time!

.... Nothing changed, it just failed from one day to the next. So
instead of fighting it we installed the free Toad for now. We will
deal with it later since time pressures do not permit playing around
with it.

I wonder if anybody has found a way to correct this "bug".

Thanks.
Jul 19 '05 #1
2 9519
Thanks Jag, that fixed it.

SV

According to a SupportLink seach on this, it suggests the following:

"Error "No CREATE [OR REPLACE] statement found to execute" when
compiling a procedure. Most likely due to an Object named "PROCEDURE".

Resolution:
TROUBLESHOOT

1. Go to Tools | Object Search
2. Type PROCEDURE in the "Search For" box.
3. Check "Object Names" click search
4. If there is an object named Procedure TOAD will not allow you to
compile any procedures in the Procedure editor. "

If this isn't it, you might want to log an issue with Quest support.

Jul 19 '05 #2

Originally posted by Salvador Valencia
Hi,

I'm getting the message "NO CREATE [OR REPLACE] statement found to
execute" in the procedure edit window of TOAD (v7.3.0.0). The code
COMPILED last night and now this morning I get this message. There are
no syntax errors since we edited and compiled the stored procedure
successfully on the free Toad.

I can copy-paste the exact code to a SQL window and it compiled. Also,
selecting the stored. proc. from the Schema Browser list compiles with
no problems.

This is a problem when trying to debug. A co-worker having the same
version had it happened to him also at the same time!

... Nothing changed, it just failed from one day to the next. So
instead of fighting it we installed the free Toad for now. We will
deal with it later since time pressures do not permit playing around
with it.

I wonder if anybody has found a way to correct this "bug".

Thanks.

When it comes to code deployment and recompile... nothing beats
sqlplus... works 100% of the time, no fuss or hassles and it comes free
with Oracle installation :->).

Regards
/Rauf Sarwar

--
Posted via http://dbforums.com
Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Joel Racicot | last post: by
2 posts views Thread by Steven Fox | last post: by
8 posts views Thread by rdemyan via AccessMonster.com | last post: by
reply views Thread by vj | last post: by
2 posts views Thread by Salvador Valencia | last post: by
53 posts views Thread by souporpower | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.