471,108 Members | 1,598 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,108 software developers and data experts.

Failing to register component using RegSvcs

I have been trying to get a previously built .NET component to run on
a Windows 2000 Server box. It's previous home was on an XP box using
..NET framework version 1.0.3328. On that machine, it ran with no
problem, but on the 2000 Server box, with version 1.1.4322, it fails
to load and gives an access denied error. I have moved the same
component to an XP box with version 1.1.4322, and it registered there
as well, but gave more warnings then it did with the earlier framework
version. Here are the outputs from the three runs:

Original XP box with 1.0.3328:
C:\test>C:\WINDOWS\Microsoft.NET\Framework\v1.0.33 28\RegSvcs.exe
app1.dll
/appname:app1
Microsoft (R) .NET Framework Services Installation Utility Version
1.0.3328.4
Copyright (C) Microsoft Corporation 1998-2001. All rights reserved.

WARNING: The class app1.ServiceInterface' has no class interface,
which means that unmanaged late bound calls cannot take advantage of
AutoComplete methods.
Installed Assembly:
Assembly: C:\test\app1.dll
Application: app1
TypeLib: c:\test\app1.tlb

New XP box with 1.1.4322:
C:\test>C:\WINDOWS\Microsoft.NET\Framework\v1.1.43 22\RegSvcs.exe
app1.dll
/appname:app1
Microsoft (R) .NET Framework Services Installation Utility Version
1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.

WARNING: The class 'app1.ServiceInterface' has no class interface,
which means that unmanaged late bound calls cannot take advantage of
AutoComplete methods.
WARNING: The assembly does not declare an ApplicationAccessControl
Attribute. Application security will be enabled by default.
Installed Assembly:
Assembly: C:\test\app1.dll
Application: app1
TypeLib: C:\test\app1.tlb
Windows 2000 Server box with 1.1.4322:
C:\test>C:\WINNT\Microsoft.NET\Framework\v1.1.4322 \RegSvcs.exe
app1.dll /appname:app1
Microsoft (R) .NET Framework Services Installation Utility Version
1.1.4322.573
Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.
The following installation error occurred:
1: Failed to load assembly 'c:\test\app1.dll'.
2: Access is denied: app1.dll'.
Any suggestions on how I can get this to load on the 2000 Server box
or what the root cause of this failure might be?
Nov 22 '05 #1
1 4318
As a follow up to anyone else who runs into a similar problem, the
security permissions apparently don't move across for the dll when
going to 2000 Server or my security defaults are different on that
box. I just needed to go to the permissions for the DLL and give
administrator "Full Control" under the Security tab. Then everything
worked.
Nov 22 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Karuppasamy | last post: by
1 post views Thread by J. P. Young | last post: by
reply views Thread by Boomessh | last post: by
3 posts views Thread by msuk | last post: by
4 posts views Thread by Mihiri | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.