473,854 Members | 1,580 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Could not load file or assembly 'App_Web_tod59g a8' and similar

I'm working in the migration of an asp.net application in 1.1 to 2.0.
I'm new to this application, just worked with that some days.
Today, I decided to open the project in VS.2005 and everything seemed
to be fine, all opened and everything was migrated. I have been working
on improvements on it this day.

However, I found that sometimes I get this error :

"Could not load file or assembly 'App_Web_tod59g a8, Version=0.0.0.0 ,
Culture=neutral , PublicKeyToken= null' or one of its dependencies. The
system cannot find the file specified"

The error always appears to point to places of code where user controls
are declared. The "App_Web_xx xxx" assembly seems to be a random name
choosen by VS.Net to rename my binaries or something like that.
The error is gone by either restarting the web services, or closing and
reopening visual studio or both.
Anyone has ever experimented this error ? Any clue ?

Nov 20 '05 #1
3 3434
No one ?

Nov 21 '05 #2
cr************@ hotmail.com wrote on 19 Nov 2005:
I'm working in the migration of an asp.net application in 1.1 to 2.0.
I'm new to this application, just worked with that some days.
Today, I decided to open the project in VS.2005 and everything seemed
to be fine, all opened and everything was migrated. I have been working
on improvements on it this day.

However, I found that sometimes I get this error :

"Could not load file or assembly 'App_Web_tod59g a8, Version=0.0.0.0 ,
Culture=neutral , PublicKeyToken= null' or one of its dependencies. The
system cannot find the file specified"

The error always appears to point to places of code where user controls
are declared. The "App_Web_xx xxx" assembly seems to be a random name
choosen by VS.Net to rename my binaries or something like that.
The error is gone by either restarting the web services, or closing and
reopening visual studio or both.
Anyone has ever experimented this error ? Any clue ?


I get this error too. It shows up every few days, sometimes after only a
few hours. But of course, the file is where it should be.

<H1>Server Error in '/' Application.
<HR width="100%" color=silver SIZE=1>
</H1>
<H2><I>Could not load file or assembly 'App_Web_gvvevr sq, Version=
0.0.0.0, Culture=neutral , PublicKeyToken= null' or one of its
dependencies. The system cannot find the file specified.</I> </H2><FONT
face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif "><B>
Description: </B>An unhandled exception occurred during the execution of
the current web request. Please review the stack trace for more
information about the error and where it originated in the code. <BR><BR>
<B>Exception Details: </B>System.IO.Fil eNotFoundExcept ion: Could not load
file or assembly 'App_Web_gvvevr sq, Version=0.0.0.0 , Culture=neutral ,
PublicKeyToken= null' or one of its dependencies. The system cannot find
the file specified.<BR></FONT>

--
Eric Falsken
Technical Evangelist: db4o
web: www.db4o.com
email: er**@db4o.com
skype: efalsken
Dec 4 '05 #3
Eric Falsken <er**@db4o.co m> wrote on 04 Dec 2005:
cr************@ hotmail.com wrote on 19 Nov 2005:
I'm working in the migration of an asp.net application in 1.1 to 2.0.
I'm new to this application, just worked with that some days.
Today, I decided to open the project in VS.2005 and everything seemed
to be fine, all opened and everything was migrated. I have been
working on improvements on it this day.

However, I found that sometimes I get this error :

"Could not load file or assembly 'App_Web_tod59g a8, Version=0.0.0.0 ,
Culture=neutral , PublicKeyToken= null' or one of its dependencies. The
system cannot find the file specified"

Only solution I've found so far is to stop the W3SVC (WWW Publisher
Service) and delete all the files in
C:/Windows/Microsoft.NET/Framework/v2.0.50527/Temporary ASP.NET Files/*

When you first hit the website, it will be recompiled automatically.

Running aspnet_compiler -c -m /LM/W3SVC/nnn/ROOT/ dosn't seem to have any
effect.

--
Eric Falsken
Technical Evangelist: db4o
web: www.db4o.com
email: er**@db4o.com
skype: efalsken
Dec 4 '05 #4

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

4
49033
by: Ed Sutton | last post by:
I have been searching for how to get an icon resource and load it into an ImageList. I added an *.ico file to my project and set the files "Build Action" to "Embedded Resource". Is there any easy way to do this? This was easy to do in the old MFC. I can not find the answer in C#. I also need to embed an XML file into the resource and load it at run time. I am hoping once I figure out how to load an icon resource then loading an XML...
2
568
by: Eric Falsken | last post by:
Eric Falsken <eric@db4o.com> wrote on 04 Dec 2005: > craigkenisston@hotmail.com wrote on 19 Nov 2005: > >> I'm working in the migration of an asp.net application in 1.1 to 2.0. >> I'm new to this application, just worked with that some days. >> Today, I decided to open the project in VS.2005 and everything seemed >> to be fine, all opened and everything was migrated. I have been >> working on improvements on it this day. >>
1
10811
by: urs | last post by:
Two days ago, I built an ASP.NET 2.0 application and published it on a shared IIS 6 Web server. After publishing, and during the whole day, it worked fine. The server remained untouched since. Today, I wanted to access the home page of the application again with a browser. But instead of the proper page, I just got an ugly message: Server Error in '/' Application.
1
3577
by: ddelaney | last post by:
I've seen this posted before in many places, but have yet to find a real fix. I have a web application on dev server right now, and randomly, hours or days, it returns the expception posted below. If I copy the incHeader.ascx.vb over to the server again, it appears to recompile and works fine, again, for random period of times. Even precompiling is no help. Is there a fix or workaround so this can some stability? Any help at all is...
4
3988
by: Richard Bysouth | last post by:
Hi I am running a site built on asp.net 1.1 on a windows server 2003 (which is running asp.net 2.0 - shared hosting at my webhost). The site is low traffic and very simple (mostly static text apart from a couple of usercontrols that pull info from a sql db). The problem I'm getting is that it will run fine for a few days, then suddenly the following error will occur: --------------------------------------------------
2
151664
by: antonyliu2002 | last post by:
I am testing AJAX. I've downloaded the AJAX Extension and the CTP December package and installed on BOTH my development machine and the production server. Then I created a very very simple web application, which contains a button and a label. When the button is clicked, some message is shown on the label. That's it. The AJAX works great on my development machine, but on the production server, I got the typical error as follows:
1
18314
by: naimishranderi | last post by:
Hello friends I am using ASP.NET 2.0 and SQL Server 2000 for DB synchronization(replication) project. When I am running this web application on local machine it running fine, but when I deploy it using FTP s/w to hosting server I got error following. Click here to see web page www.aus-business.com/naimish/replication Parser Error Message: Could not load file or assembly 'Microsoft.SqlServer.ConnectionInfo, Version=9.0.242.0,...
3
10788
by: pratikkagda | last post by:
Hi all, My system contains Framework 3.5 with visual studio 2008 as well as 2005; here I have developed an application with crystal report with framework 2.0. It is working great in my system but when I upload this project into our production server (Production server only contains Framework 2.0 and IIS) and deployed the site to the production server with necessary assemblies, but itís getting error as bellow. In my system I could not find...
0
3968
by: Andy | last post by:
Thanks Peter, I thought I'd give an update on this problem. My application had 2 assemblies that contained classed for the Data access and business logic layer. It was on one of them that I was getting the Access denied error. After checking different settings and googling I wasnt able to pinpoint the problem and as a temporary fix I decided to merge the two assemblies into one, my logic being no offending assembly no access denied...
1
8367
by: Steve Wofford | last post by:
I am recieving the following. This happens when I moved it from my development system to our production SBS 2003 w/ latest .net frameworks and service packs . I developed under XPSP2 and VS2008. The error is pointing to the Web.Config of my application. System.Data.Entity was missing from the server, but was on the dev system. I tried to add, but didnt help: C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5
0
9901
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, weíll explore What is ONU, What Is Router, ONU & Routerís main usage, and What is the difference between ONU and Router. Letís take a closer look ! Part I. Meaning of...
0
11025
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10682
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
10758
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10371
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
7915
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Duprť who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
5942
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4562
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4159
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.