473,602 Members | 2,861 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Server Application Error

Hello all,

I posted recently about a HTTP1.1/500 Server Error message
I was getting. I was pointed to
http://www.aspfaq.com/show.asp?id=2109.

I did everything listed in that FAQ, and I still get the
Server Application Error any time I try to access an ASP
web page. However, the web server will serve up html pages
without a problem.

To be more specific, I have done the following:

* Confirmed that in IE "friendly error messages" are
turned off
* Removed and recreated my default web site application
* Checked the "App Debugging" tab to make sure that "Send
detailed ASP error messages to client" is checked
* Uninstalled and reinstalled IIS from scratch.
* Checked my event logs and found the following warning
(not error) when I started IIS:

The server failed to load application '/LM/W3SVC/1/Root'.
The error was 'Class not registered.'

I originally saw the problem after installing VS 2003
and .NET framework 1.1, but even with those two
uninstalled, I still see the error message if I try to
load something like IISSTART.ASP.

Any ideas?

Steve

Jul 19 '05 #1
9 14678
Steve Battisti wrote:
Hello all,

I posted recently about a HTTP1.1/500 Server Error message
I was getting. I was pointed to
http://www.aspfaq.com/show.asp?id=2109.

I did everything listed in that FAQ, and I still get the
Server Application Error any time I try to access an ASP
web page. However, the web server will serve up html pages
without a problem.

To be more specific, I have done the following:

* Confirmed that in IE "friendly error messages" are
turned off
* Removed and recreated my default web site application
* Checked the "App Debugging" tab to make sure that "Send
detailed ASP error messages to client" is checked
* Uninstalled and reinstalled IIS from scratch.
* Checked my event logs and found the following warning
(not error) when I started IIS:

The server failed to load application '/LM/W3SVC/1/Root'.
The error was 'Class not registered.'


I've never experienced this error so I did a Google search. Here are the
results.
http://www.google.com/search?sourcei...gistered%2E%27

In particular, this seems promising:
http://www.iisfaq.com/default.aspx?View=A318

If you provide the event id and source from the event viewer, I'll check a
couple more things out.

Bob Barrows

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 19 '05 #2
I haven't checked out your suggestions yet, but here is
the event ID and source:

Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 36
Date: 12/19/2003
Time: 10:59:38 PM
User: N/A
Computer: DIM8200
Description:
The server failed to load
application '/LM/W3SVC/1/Root'. The error was 'Class not
registered
'.
For additional information specific to this message
please visit the Microsoft Online Support site located
at: http://www.microsoft.com/contentredirect.asp.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

-----Original Message-----
I've never experienced this error so I did a Google search. Here are theresults.
http://www.google.com/search?sourceid=navclient&ie=UTF- 8&oe=UTF-8&q=The+server+ failed+to+load+ application+%27 %
2FLM%2FW3SVC%2F 1%2FRoot%27%2E+ The+error+was+%
27Class+not+reg istered%2E%27
In particular, this seems promising:
http://www.iisfaq.com/default.aspx?View=A318

If you provide the event id and source from the event viewer, I'll check acouple more things out.

Bob Barrows

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so Idon't check it very often. If you must reply off-line, then remove the"NO SPAM"
.

Jul 19 '05 #3
Steve Battisti wrote:
I haven't checked out your suggestions yet, but here is
the event ID and source:

Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 36
Date: 12/19/2003
Time: 10:59:38 PM
User: N/A
Computer: DIM8200
Description:
The server failed to load
application '/LM/W3SVC/1/Root'. The error was 'Class not
registered
'.
For additional information specific to this message
please visit the Microsoft Online Support site located
at: http://www.microsoft.com/contentredirect.asp.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

This is all I could come up with:
http://www.eventid.net/display.asp?e...6&source=W3SVC

Bob
Jul 19 '05 #4
How does one run SYNCIWAM?
-----Original Message-----
Steve Battisti wrote:
Hello all,

I posted recently about a HTTP1.1/500 Server Error message I was getting. I was pointed to
http://www.aspfaq.com/show.asp?id=2109.

I did everything listed in that FAQ, and I still get the
Server Application Error any time I try to access an ASP
web page. However, the web server will serve up html pages without a problem.

To be more specific, I have done the following:

* Confirmed that in IE "friendly error messages" are
turned off
* Removed and recreated my default web site application
* Checked the "App Debugging" tab to make sure that "Send detailed ASP error messages to client" is checked
* Uninstalled and reinstalled IIS from scratch.
* Checked my event logs and found the following warning
(not error) when I started IIS:

The server failed to load application '/LM/W3SVC/1/Root'. The error was 'Class not registered.'

I've never experienced this error so I did a Google

search. Here are theresults.
http://www.google.com/search?sourceid=navclient&ie=UTF- 8&oe=UTF-8&q=The+server+ failed+to+load+ application+%27 %
2FLM%2FW3SVC%2F 1%2FRoot%27%2E+ The+error+was+%
27Class+not+reg istered%2E%27
In particular, this seems promising:
http://www.iisfaq.com/default.aspx?View=A318

If you provide the event id and source from the event viewer, I'll check acouple more things out.

Bob Barrows

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so Idon't check it very often. If you must reply off-line, then remove the"NO SPAM"
.

Jul 19 '05 #5
Steve Battisti wrote:
How does one run SYNCIWAM?

There's an article about it on www.aspfaq.com. A quick search should get it
for you.

Bob Barrows

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 19 '05 #6
Curiouser and curiouser, as someone once wrote.

Ran SYNCIWAM, and got the following:

Error: 8004E00F:

When I ran it 'verbose', I got the following:

Name, AppIsolated, Package ID
Root, 0,
IISHelp, 2,

Out of process applications defined:
Count:1
{3D14228D-FBE1-11d0-995D-00C04FD919C1}

Error: 8004E00F:

Oddly enough, this is a brand spanking new installation of
XP Pro, so it's not like my system is filthy with junk,
either.

As usual, any suggestions appreciated.

Steve
Jul 19 '05 #7
Steve Battisti wrote:
Curiouser and curiouser, as someone once wrote.

Ran SYNCIWAM, and got the following:

Error: 8004E00F:

When I ran it 'verbose', I got the following:

Name, AppIsolated, Package ID
Root, 0,
IISHelp, 2,

Out of process applications defined:
Count:1
{3D14228D-FBE1-11d0-995D-00C04FD919C1}

Error: 8004E00F:

Oddly enough, this is a brand spanking new installation of
XP Pro, so it's not like my system is filthy with junk,
either.

As usual, any suggestions appreciated.

Steve


I'm stumped. You may wish to try over at .inetserver.iis

Please let us know what the solution is.

Bob Barrows

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 19 '05 #8
Bob,

Thanks for all of your help. Amazingly, I got it working.
I'm not 100% certain, but I believe the reason is because
the Distributed Transaction Coordinator service on my
machine was set to "disabled".

After I enabled it, I uninstalled and reinstalled, and now
it works like a charm. I don't know if that makes any
sense, but there you go.

Thanks again for your help!

Steve
Jul 19 '05 #9
See link: http://www.brooksyounce.com/xp_asp_fix.htm

This guy is a genius!
THANK YOU - IT WORKED!!!

BRIEFLY (if his site disappears) and all obvious things like checking
Event Log, that MSDTC is running, some other basic t/s completed, etc.
and problem persists:

-START-
cd %windir%\system 32\inetsrv
rundll32 wamreg.dll, CreateIISPackag e
regsvr32 asptxn.dll
IISRESTART
-END-

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 19 '05 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

5
4655
by: VinnieT | last post by:
I have a load balanced system that consists of 3 production servers. There are about 20 different applications that are used on these boxes. One of my applications in particular is used more than the others. Since updating 2 applications, I have had problems on the event log of the servers, following stopping of the aspnet_ws.exe process. Something is causing the following error in the windows application event log: The description for...
6
635
by: Javier Cortés Cortés | last post by:
i am getting this error when i am trying to access any file(with the ext. aspx) from my remote server. the error is : Server Error in '/' Application. ---------------------------------------------------------------------------- ---- Runtime Error Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application
1
3150
by: Keith | last post by:
All, I have been told this is an ASP.NET issue and not an IIS issue, so I am posting this here. I have a problem with ASP.NET returning an HTTP 500 error when trying to run ASPX pages on Windows Server 2003 Enterprise Edition Only. This works on Windows 2000, Windows 2003 Web Edition and
9
647
by: Steve Buster | last post by:
All right, I have read every forum, newsgroup etc about this issue and no one seems to know how to fix it. I am getting a "Server Application Unavailable" exception running my .NET 1.1 application. I use W2K SP4 and have applied the hot Fix KB824146 and KB824105, both IE fixes. I don't have VS installed because this is a Quality Environment. I do have .NET SDK and .NET 1.1 Runtime installed. I can't change my APSNET user to run as...
4
5380
by: tommy | last post by:
hello everbody, i write a little asp-application with forms-authentication. i copy my aspx-files with web.config to my webspace and i get the error above... i tried to set the custom-errors-tag ="off" but nothing happens.... what is my failure????
6
3499
by: AlanS | last post by:
I have used Visual Studio for about 8 months. I have developed some ASP solutions. I had to get on with some other things and have not worked with ASP.NET for a couple months. In the meantime, I have upgraded to .NET Framework 200 V1.1. Over the week end I had to go back to work on a project that needed some changes. I get the following error when I try to open an existing project or create a new one. I have XP Professional An error...
0
1667
by: Darren | last post by:
Hi, I get the above error message when I try to run my page on the remote server. As I am a newbie with .net, I chose Project | Copy to copy the files needed to a seperate local directory then copied these to the remote server via FTP. The page works fine on my local machine (WinXP Pro, VS.Net etc...) Page code is: -------------------------
12
26791
by: Kevin Farless | last post by:
Hi all, I'm having trouble viewing any .aspx pages on my hosting company's server. The server is a new box running Windows Server 2003 default installation. I'm the first client to try using ASP.NET on this box and the administrator of the server has never setup an ASP.NET site before, so most likely the problem I'm experiencing is server settings related. Note in the Web.config below that the <customErrors mode="Off"/> is present,...
5
6557
by: Bruce Schechter | last post by:
I just started to develop an ASP.NET application in vs.net 2003 . But each time I try to execute the application (which is basically empty so far), I get a dialog box titled "Microsoft Development Environment" with this message: "Error while trying to run project: Unable to start debugging on the web server. Server-side error occurred on sending debug HTTP request. Make sure the server is operating correctly. Verify there are no...
17
5080
by: Jon B | last post by:
Hi All! I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to view this site on my local Windows XP machine, I get "Server Unavailable". If I switch the Windows XP IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because I'm trying to run an ASP.NET 2 site with 1.1 framework). I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the...
0
7993
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
8405
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
8056
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
8270
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
6730
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
5440
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
1
2424
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
1
1511
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
0
1256
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.