473,856 Members | 1,576 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Run-time error 80004005 - HELP!

I am about to completely lose what is left of my poor mynd! The historical
dissertation gets rather verbose, so I hope you can wade through it all. I
really need some help on this one or I'm looking at rewriting all my hard
work in something else (wasting probably a month or more).

(If you want to run and hide now, the error message is "The decimal field's
precision is too small to accept the numeric you attempted to add." I
haven't yet found any real solution out there including MS's KB saying the
problem was first fixed in Jet v4.0 SP6 ... and I'm running Jet v4.0 SP8.)
All the tech tips I pulled up with Google seem to wander off to no solution.
I found one ancient newsgroup posting left unanswered. I've really been
trying to research and resolve this problem.

I'm using Access 2000 on a Win2K Pro with MDAC v2.8 and, as already
mentioned, Jet v4.0 SP8. All Connections and Recordsets are ADODB. The
destination table is a linked table originating from a FoxPro v3 database.
(Yeah, I know it's an antique, but I have to play the cards dealt.)

The link connection to the FoxPro tables is done through an ODBC DSN using
the "Microsoft Visual FoxPro Driver" (v6.01.8630.0, if it really matters).
The ODBC DSN is using the "Database type" of "Visual FoxPro database(.DBC)"
rather than the "Free Table directory." The Driver options are Collating
sequence => Machine; Exclusive => Off; Null => Off; Deleted => On; Fetch
data in background => Off. According to several MS KB articles, the "Visual
Foxpro database" option is the only method available. Just to make matters
worse, it appears MS is letting FoxPro die a slow death.

Using "Visual FixPro database (.DBC)" is required as it is the only way
Access will allow me a write enabled linked table. "Null = Off" is required
because old FoxPro v3 tables don't like fields populated with Null values.

I've tried programmaticall y building a Connection and relinking the tables
(and just linking them as new tables) using some ADOX methods, but kept
getting an error saying it "Could Not Find Installable ISAM". (There is no
ISAM driver for FoxPro anymore.) (MS KB 209805, 225861)

So ... I went back to ADO and CurrentProject. Connection.

With the FoxPro tables linked (and write enabled), I'd do something like:

Dim cnLocal as New ADODB.Connectio n
Dim rsMyTable as New ADODB.Recordset
Set cnLocal = CurrentProject. Connection
rsMyTable.Curso rLocation = adUseClient
rsMyTable.Open "MYTABLE", cnLocal, adOpenDynamic, adLockPessimist ic,
adCmdTable
With rsMyTable
.AddNew
!thisfield = thisValue
!thatfield = thatValue
.Update
End With

Everything runs fine until I hit one record where the value I intend to
inject is the numeric 240 originating from a column defined as Decimal with
a Precision of 9 and a Scale of 5. (Smaller numeric values go through just
fine, but I do not know precisely where the majik line of death is.)

The destination FoxPro column (by Access's definition) is Decimal with a
Precision of 11 and a Scale of 9.

Last time I checked, 240 fits well within the confines of the column
properties.

Just for grins, I went to the third-party application that actually uses the
FoxPro database, brought up the appropriate transaction form and updated a
record with the numeric value 240 just to prove the FoxPro database would
accept the value. Life was good, so I thought.

Going back to Access 2000, I brought up the table data, scrolled down to the
record and found "#Error" across all the columns of that one record. If I
let Access camp out with that record displayed for a length of time
(minutes), it would eventually burp out the error message mentioned at the
top.

Since Connection.Exec ute will process the basic SQL commands, I tried the
longhand approach. Leaving the recordset closed, I crafted an INSERT
statement and started pushing in records that way.

Again, life was fine ... until I reached that one entry with a numeric value
of 240, at which point I got the error message again.

I took the time to check the version of each and every DLL in the Jet v4.0
SP8 KB article (MS KB 239114). Every one checks out except:

Dao360.dll should be v3.60.8025.0 (is higher at v3.60.8618.0)
Msexcl40.dll should be v4.0.8015.0 (is higher at v4.0.8618.0)
Msjet40.dll should be v4.0.8015.0 (is higher at v4.0.8618.0)
Msjetoledb40.dl l should be v4.0.8015.0 (is higher at v4.0.8227.0)
Msjint40.dll should be v4.0.8015.0 (is LOWER at v4.0.6508.0)
Msjtes40.dll should be v4.0.8015.0 (is higher at v4.0.8618.0)

The one that I suspect is MSJINT40.DLL. According to KB 239114, it is from
Jet v4.0 SP7. Reapplying Jet SP8 and/or MDAC v2.8 does nothing to upgrade
the version of this file.

I would really appreciate it if some knowledgeable individual here could
help me resolve this roadblock.

Nov 12 '05 #1
1 15949

"starwars" <no****@tatooin e.homelinux.net > wrote in message
news:1c******** *************** *******@tatooin e.homelinux.net ...
postgresql doesn't have this problem.


I think the cause has been discovered. 11 digits with 9 decimals allows for
a maximum number of 99.999999999.

Although the schema calls for numbers < 100, the storage allocated to the
column may have been rounded up to fit a comfortable number of words. Access
(and Jet) are taking the column definition literally causing them to crash
and burn on numbers => 100 while applications written in FoxPro, and also
Crystal Reports, just chug on by with no problems.

I'm going after the third-party application vendor now to see if the schema
definition could be changed without impacting the application and for
confirmation or denial of my hypothesis.
Nov 12 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
4934
by: leroybt.rm | last post by:
Can someone tell me how to run a script from a interactive shell I type the following: >>>python filename >>>python filename.py >>>run filename >>>run filename.py >>>/run filename >>>/run filename.py
4
3222
by: Ed | last post by:
Hello, I took a course in asp about 2 years ago and I was practicing with IIS 5.0. Then I put it down for a while. Now trying to get back to it. I can't run asp files from subdirectories of my root directory, but I can run asp files from the root directory of my website and I can run htm files from the subdirectories. If I run localhost/mytest.asp
2
2551
by: Jenna Olson | last post by:
Hi all- I've never seen this particular issue addressed, but was wondering if there's anything to support one way or another. Say I have a class: class ManipulateData { public: ManipulateData(const char* Path-To-Some-Text-File) { ... }
15
4294
by: mg | last post by:
How can I run an .exe using C# from within the code behind of a WebForm app?
6
2645
by: billr | last post by:
I have developed a small API for taking care of a lot of boiler plate stuff in a multi formed windows application, for example setting up a messaging thread framework. New Forms, in the appllication using the API, are subclassed to a Form contained within the API, and they are controlled (controlled in this instance means, kept alive, displayed and hidden) at runtime by a thread whose responsibility is this sole task. In order to run...
13
5105
by: Bob Day | last post by:
Using vs2003, vb.net I start a thread, giving it a name before start. Code snippet: 'give each thread a unique name (for later identification) Trunk_Thread.Name = "Trunk_0_Thread" ' allow only 1 thread per line Trunk_Thread.ApartmentState = ApartmentState.STA
9
4697
by: Brett Wesoloski | last post by:
I am new to VS2005. I changed my program.cs file to be a different form I am working on. But when I go to run the application it still brings up the form that was originally declared as new. When I put in a break point the program does not stop. It is in debug mode. If I change the program.cs file back to the form that was originally being used. The program does go into debug mode. But if I change code in that file it isn't using...
7
2955
by: Lee Crabtree | last post by:
I remember when I was first getting into .NET Forms programming that there was a rather emphatic rule about not constructing a form before calling Application.Run with it. So this: Application.Run(new Form1()); was okay, but this: Form1 form = new Form1();
3
11307
by: traceable1 | last post by:
Is there a way I can set up a SQL script to run when the instance starts up? SQL Server 2005 SP2 thanks!
7
11751
by: mxdevit | last post by:
Task: run application from ASP.NET for example, you have a button on ASP.NET page, when press this button - one application is invoked. the code to run application (for example, notepad) is (on C#) System.Diagnostics.Process.Start("notepad");
0
9921
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9765
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
11065
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
10795
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10390
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9536
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
7098
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
1
4581
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4177
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.