468,107 Members | 1,302 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Share your developer knowledge by writing an article on Bytes.

Deleting file type associations under Windows Vista WITHOUT extra software

Nepomuk
3,112 Expert 2GB
Recently, I found that I had associated a file type to notepad by mistake. This file type (let's just say, it has the extension .xyz) wasn't supposed to be opened by notepad - actually, it wasn't supposed to be opened by anything at all. However, when I tried to remove the file type association like I could in previous versions of Windows, I found that I was meeting a dead end. I could change the program, no problem at all, but removing it seemed impossible. So, I tried a few things and this is what I came up with:

This the method is, I must admit, a bit cheeky. But it works, so who cares? ;-)
First of all, open notepad. You'll have an empty file. Save this empty file as nothing.exe, choosing All Files (*.*) under the Save as type: option. Choose any place you'll remember and that you have writing access to, it doesn't matter as we'll delete it later anyway.
Next, we'll need to change the settings for this file type. There are two ways to do that. Either:
Find a xyz-file somewhere
-> do a right click on it
-> choose Properties
-> click on the Change button behind Opens with:
or:
Go to the Start-menu
-> click Default Programs
-> choose Associate a file type or protocol with a program
-> find and left click on the extension / association you're trying to delete
-> click Change program
In either case, you'll have the option to change the program to open this file type with. So, click on Browse, select the nothing.exe file you created earlier, click Open and then OK. Now delete the nothing.exe file. You're done.

Now, for those who were thinking of the commands assoc and ftype - they don't do the job. Vista (and maybe previous versions of Windows too, I don't know) seems to have separate ways of registering the associations registered with them and via the GUI. If anyone can enlighten me on this issue, they are welcome to do so.
Jul 28 '09 #1
2 4083
Open explore window and -> FolderOption->View->in that uncheck Hide extentions for known file type->apply and then OK

Now your files can be seen with thier extension now you can rename it.

revert back to previous setting to check hide extension for known filetype
hope you its help full to you
Jul 31 '09 #2
Nepomuk
3,112 Expert 2GB
That's how to change the file type extension, not it's association. But thanks for mentioning it. ^^

Greetings,
Nepomuk
Aug 5 '09 #3

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

5 posts views Thread by Eric | last post: by
6 posts views Thread by Martin Bischoff | last post: by
1 post views Thread by iwdu15 | last post: by
13 posts views Thread by James Reid | last post: by
28 posts views Thread by Tim Daneliuk | last post: by
5 posts views Thread by =?Utf-8?B?Qkw=?= | last post: by
7 posts views Thread by =?Utf-8?B?UGFycm90?= | last post: by
1 post views Thread by Solo | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.