By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,955 Members | 1,793 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,955 IT Pros & Developers. It's quick & easy.

Have to type single/double quotes twice

P: 7
Hi,
Sorry for repeating the question. I am facing problem when working in vba editor. I need to type single/double quotes twice and then delete one of them. One solution that's on the web is to change the Keyboard language in "Region and Language" to English (United States ) - US. I checked settings in my laptop and found that the keyboard language is set to English (United States) - US already. I am using Win 7. Not sure what's wrong.
Jun 24 '11 #1
Share this Question
Share on Google+
8 Replies


100+
P: 137
When you say twice do you mean two pairs of quotes (""<Some code here>""), or two quotes meaning one opening and one closing quote? ("<Some code here>")

You need to give more explanation on what you're trying to achieve.
Jun 24 '11 #2

P: 7
hi Adam
What I meant was, If i need one single/double quote, I have to type twice or have to type a character after that, in order it to become visible.
So if I type once, it does not appear. If I press double quote again or any other key, it appears.
Jun 24 '11 #3

100+
P: 137
Oh right.
That's more a laptop issue than one related specifically to MS Access or VBA.

Are you sure the setting is English (United States) and not anything like English International (United States)?
Even if it's already set to English (United States), it might be worth trying to change it to something else, log out, log in, changing it back, log out, log in, and see if that does anything.
Occasionally systems can get confused - I often have something like MS Word telling me it's using UK English spellchecking, yet it's suggesting US English spellings.
Jun 24 '11 #4

NeoPa
Expert Mod 15k+
P: 31,342
I'll move this to the Windows forum where hopefully it will find more appropriate experts.
Jun 24 '11 #5

Nepomuk
Expert 2.5K+
P: 3,112
Hi murthyspd!

I found this old thread which also talks about changing the keyboard layout. It seems, there are two English US layouts - one of them "International". That's the one you don't want. If you already have the correct one activated, try switching to the wrong one, saving the settings and testing that. It should work just like now. Then change it back. Theoretically, then it should work as you want it to.

Does that solve your problem?

Greetings,
Nepomuk
Jun 28 '11 #6

NeoPa
Expert Mod 15k+
P: 31,342
I suspect this is still the problem. You say in the OP that you already have this set to English (United States) - US already, but also that you are using Windows 7. I think it's quite possible that the ability to specify accented characters (that this problem appears to be related to) is simply found in a different place in this new version of the operating system. I suggest you check through your Control Panel applets for anything which may be related and go through the options found within them until you discover what may effect this.

Please let us know what it turns out to be if you do find it. I'm sure there will be others who also need this information. Best of luck :-)
Jun 28 '11 #7

P: 1
This has happened to me in VBA or while editing a macro. This can occur if you accidentally press CTRL + Shift at the same time while typing. Press CTRL + Shift again to undo this annoying issue. It's maddening to try and figure this out if no one else knows what in the world you are talking about!
May 9 '13 #8

P: 1
I had the exact same problem in Excel and vba. gregla1's solution worked for me. ctrl+shift pressed together toggles the problem on and off. Thanks!!
Mar 14 '17 #9

Post your reply

Sign in to post your reply or Sign up for a free account.