472,958 Members | 2,114 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,958 software developers and data experts.

Upgrade to W2003 R2 SP2 leaves USB Memory Sticks without Drive Letter


I have been helping a friend of mine to upgrade his W2K Server to W2K3. The upgrade did not go smoothly (it took forever) but in the end we managed to get it to work. Then we proceeded to update to current status with all the available patches. As it stands right now, it is up to date, stable, running OK and all the hardware has been recognized and works reliably with the correct drivers.

The problem showed up when they tried to use USB Flash Drives as manual backups. They do local backups and also off-site. They backup business data manually (i.e. no app) by simply copying the info into USB Flash Drives.

They tried to use the same USB Drives they were using with W2K but suddenly none of them works. The symptoms are all the same:

The drives are recognized as USB Mass Storage Device and Generic Flash Disk USB Device (as it should). But no drive letter is assigned. The drives are not visible in Explorer.

In Disk Management the Flash Drives are visible but with no letter assigned to them. If one tries to assign a letter, Disk Management accepts the command but does not provide the pop-up window to make such change. If one tries to format the Flash Drives it displays the message: Logical Disk Manager - The format did not complete successfully.

There are no errors related to this in any shape or form in any Event Viewer.

The USB driver for flash drives belongs to MS and it is the current one 10/1/2002 v5.2.3790.0

USB Hubs and Host Controllers are all up to date and working properly (any other USB device that is not a memory works properly, such as HDDs, CD/DVDs, cameras, etc.)

I have tried all the standard cures out there. Namely:

- Change the drive letter: Disk Management won't do it

- Format: error message

- Boot in Safe Mode: USB not assigned a drive letter, same as in normal boot

- Other USB drives: same result (also tested these drives -7- in other PCs and are all OK).

- Others: such as Geparted automount enable and running DriveCleanUp to remove all the dead entries in the registry from:

Removes from the device tree non present
- USB hubs
- USB mass storage devices
- USB Disk devices
- USB CDROM devices
- USB Floppy devices
- USB Storage Volumes
- USB WPD devices (Vista, Win7 only)

and their linked registry items under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\DeviceClasses
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\MountPoints2
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\MountPoints2\CPC\Volume

Then I started searching for XP-related issues (since W2K3 is essentially XP) and came across this article: http://support.microsoft.com/kb/925196?wa=wsignin1.0

This is simply a KB indicating that sometimes two entries are to be removed from the registry (UpperFilters and LowerFilters from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}) to solve this issue.

Upon removal of said entries the USB Flash drives were recognized OK and assigned drive letters OK. However, the same process re-assigned all the HDD Drive Letters to the point of interfering with normal W2K3 operations. This would not have been so bad, if it would be possible to revert to the original drive letter using Disk Management, however, if one tries to access it, it hungs forever at the stage of: "Connecting to Logical Disk Management service". In other words, Disk Manager becomes inaccessible. Reverting the Registry deletions gets the system back to the original state (i.e. not assigning USB letters, but assigning correct HDD letters).

In other words, the issue is directly related to the registry and has nothing to do with hardware (MOBO or flash drive) or software (third party or the OS) issues.

Any idea would be greatly appreciated indeed!
Jan 2 '13 #1
0 1644

Sign in to post your reply or Sign up for a free account.

Similar topics

by: amnésia | last post by:
Hi there. I have to change the drive letter where SQL server have his datfiles (master included). If I do that, ob the SQL fail to start, becouse it's unable to find the master datfiles. Is it...
by: BK Drake | last post by:
I am trying to assign a drive letter to a hidden partition. I have a hard drive that has 2 paritions - a system and a data partition. When I retore with an image the system drive the data drive...
by: john doe | last post by:
How can I use WMI or a WqlObjectQuery to find the hard drive letter of the physical drive location index. For example the following code will give me the physical drive location:...
by: jimdscudder | last post by:
How can I use WMI or a WqlObjectQuery to find the hard drive letter of the physical drive location index. For example the following code will give me the physical drive location:...
by: sanjana | last post by:
hi i m using the win32_diskdrive class for detecting a memory card insertion and removal..and this class detects memory card(sd card..etc) insertion removal from the device the deviceid...
by: unknown; | last post by:
hi, i want to write an application who can acces a disk/partition in windows xp. I know how to do that if the disk/partition has a drive letter. But in this case the disk has no driveletter and...
by: Jim Carlock | last post by:
function CreateMyDataBaseFile($FQFN, $UID, $PW) { $db = "sqlite:" . $FQFN; $sql = "CREATE TABLE Customers(name1 TEXT, name2 TEXT);"; $dbh = new PDO($db, $UID, $PW); $dbh->exec($sql); $dbh =...
by: Talal Itani | last post by:
I am writing code that accesses an MP3 player plugged to a USB port. The MP3 player is not showing up as a drive letter. With explorer, I see the drive, with it's name, but no drive letter is...
by: BigM | last post by:
Hi Guys, I am working up a little 'documents' section to an app of mine, where people can add links to docs on various share drives in our LAN, and they are displayed along with other details and...
by: Ste | last post by:
Good morning to all. I have made a class to manage network connections using APIs WNetAddConnection2A WNetCancelConnection2A WNetGetConnection. I can connect and disconnect remote folder...
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 4 Oct 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: Aliciasmith | last post by:
In an age dominated by smartphones, having a mobile app for your business is no longer an option; it's a necessity. Whether you're a startup or an established enterprise, finding the right mobile app...
by: tracyyun | last post by:
Hello everyone, I have a question and would like some advice on network connectivity. I have one computer connected to my router via WiFi, but I have two other computers that I want to be able to...
by: giovanniandrean | last post by:
The energy model is structured as follows and uses excel sheets to give input data: 1-Utility.py contains all the functions needed to calculate the variables and other minor things (mentions...
by: Teri B | last post by:
Hi, I have created a sub-form Roles. In my course form the user selects the roles assigned to the course. 0ne-to-many. One course many roles. Then I created a report based on the Course form and...
by: nia12 | last post by:
Hi there, I am very new to Access so apologies if any of this is obvious/not clear. I am creating a data collection tool for health care employees to complete. It consists of a number of...
by: NeoPa | last post by:
Introduction For this article I'll be focusing on the Report (clsReport) class. This simply handles making the calling Form invisible until all of the Reports opened by it have been closed, when it...
by: GKJR | last post by:
Does anyone have a recommendation to build a standalone application to replace an Access database? I have my bookkeeping software I developed in Access that I would like to make available to other...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.