By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,913 Members | 1,379 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,913 IT Pros & Developers. It's quick & easy.

Troubleshooting in installing Bugzilla-3.2.9

P: 1
Software error:

Base class package "Template::Parser" is empty.
(Perhaps you need to 'use' the module which defines that package first,
or make that module available in @INC (@INC contains: . lib D:/xampp/perl/lib D:/xampp/perl/site/lib).
at Bugzilla/Template/Parser.pm line 26
BEGIN failed--compilation aborted at Bugzilla/Template/Parser.pm line 26.
Compilation failed in require at Bugzilla/Template.pm line 45.
BEGIN failed--compilation aborted at Bugzilla/Template.pm line 45.
Compilation failed in require at Bugzilla.pm line 45.
BEGIN failed--compilation aborted at Bugzilla.pm line 45.
Compilation failed in require at D:/xampp/htdocs/bugzilla-3.2.9/index.cgi line 34.
BEGIN failed--compilation aborted at D:/xampp/htdocs/bugzilla-3.2.9/index.cgi line 34

What error is this? and how to troubleshoot this error? Please reply
Dec 4 '10 #1
Share this Question
Share on Google+
1 Reply


numberwhun
Expert Mod 2.5K+
P: 3,503
Bugzilla is pretty easy to install, but it takes a bit of work due to its prerequisites. This sounds like a case of just trying to install without following the installation guide, but that's just a guess.

Check here for the part of the install guide that talks about Perl and the Required and Optional prerequisites. You will need to install all the required modules and any of the optional modules that you may need to suit your requirements. The guide is there for a reason, I would follow it to install Bugzilla as it will save you headaches.

Regards,

Jeff
Jun 7 '11 #2

Post your reply

Sign in to post your reply or Sign up for a free account.